{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.james:james-server. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-7611 exists.","fix":"Upgrade org.apache.james:james-server to 2.3.2.1 or later.","what":"CVE-2015-7611 is a high-severity command injection vulnerability in n/a, published on 7 Jun 2016. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-7611 and fix it if it is affected.\n\nWhat it is: CVE-2015-7611 is a high-severity command injection vulnerability in n/a, published on 7 Jun 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-7611 exists.\n\nAffected packages and fixed versions:\n- org.apache.james:james-server (Maven): affected all versions; fixed in 2.3.2.1\n- org.apache.james:james-server (Maven): affected all versions; fixed in 2.3.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-7611/ (Markdown: https://insights.sbomify.com/CVE-2015-7611/index.md)","id":"CVE-2015-7611","markdown":"https://insights.sbomify.com/CVE-2015-7611/index.md","name":"CVE-2015-7611","record":{"aliases":["GHSA-cgvf-22vv-83h5"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache James Server","requires_auth":"none","summary":"Attackers can execute arbitrary system commands on Apache James Server when using file-based user repositories.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"james_server","vendor":"apache"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Apache James Server 2.3.2, when configured with file-based user repositories, allows attackers to execute arbitrary system commands via unspecified vectors.","ecosystems":["Maven"],"exploits":{"exploitdb":1,"first_seen":"2015-10-01","github_poc":0,"max_poc_stars":null,"metasploit":1,"nuclei":0,"refs":[{"date":"2015-10-01","kind":"metasploit","ref":"exploit/linux/smtp/apache_james_exec","stars":null,"title":"Apache James Server 2.3.2 Insecure User Creation Arbitrary File Write"},{"date":"2020-02-24","kind":"exploitdb","ref":"48130","stars":null,"title":"Apache James Server 2.3.2 - Insecure User Creation Arbitrary File Write (Metasploit)"}],"tier":"weaponised"},"has_fix":true,"headline":"Apache James Server OS Command Injection","id":"CVE-2015-7611","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"command_injection","year":"2015"},"n_packages":2,"n_references":6,"next":{"headline":"Cross-site request forgery in n/a","id":"CVE-2015-7612"},"packages":[{"ecosystem":"Maven","fixed":["2.3.2.1"],"introduced":["0"],"last_affected":[],"package":"org.apache.james:james-server","purl":null,"source":"GHSA-cgvf-22vv-83h5"},{"ecosystem":"Maven","fixed":["2.3.2.1"],"introduced":["0"],"last_affected":[],"package":"org.apache.james:james-server","purl":"pkg:maven/org.apache.james/james-server","source":"GHSA-cgvf-22vv-83h5"}],"prev":{"headline":"Cross-site request forgery in n/a","id":"CVE-2015-7610"},"products":["n/a"],"published":"2016-06-07","related":[{"cvss_score":8.6,"headline":"Apache James: denial of service through the use of IMAP literals","id":"CVE-2024-37358","kev_date_added":null,"published":"2025-02-06"},{"cvss_score":7.8,"headline":"Apache James Privilege Escalation","id":"CVE-2017-12628","kev_date_added":null,"published":"2017-10-20"},{"cvss_score":6.5,"headline":"Apache James: denial of service through JMAP HTML to text conversion","id":"CVE-2024-45626","kev_date_added":null,"published":"2025-02-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can execute arbitrary system commands on Apache James Server when using file-based user repositories.","url":"https://insights.sbomify.com/CVE-2015-7611/"}