# CVE-2015-7611: Apache James Server OS Command Injection

> Attackers can execute arbitrary system commands on Apache James Server when using file-based user repositories.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jun 2016
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-cgvf-22vv-83h5

## What is CVE-2015-7611?

CVE-2015-7611 is a high-severity command injection vulnerability in n/a, published on 7 Jun 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache James Server 2.3.2, when configured with file-based user repositories, allows attackers to execute arbitrary system commands via unspecified vectors.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2015-7611?

2 open source packages ship an affected version, including org.apache.james:james-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.james:james-server` | Maven | All versions | 2.3.2.1 |
| `org.apache.james:james-server` | Maven | All versions | 2.3.2.1 |

Products: Apache James Server.

## How do I fix CVE-2015-7611?

Upgrade org.apache.james:james-server to 2.3.2.1 or later.

## Is CVE-2015-7611 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-7611 exists.

Public exploit code:

- Apache James Server 2.3.2 Insecure User Creation Arbitrary File Write (metasploit)
- Apache James Server 2.3.2 - Insecure User Creation Arbitrary File Write (Metasploit) (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2024-37358](https://insights.sbomify.com/CVE-2024-37358/): Apache James: denial of service through the use of IMAP literals (high 8.6)
- [CVE-2017-12628](https://insights.sbomify.com/CVE-2017-12628/): Apache James Privilege Escalation (high 7.8)
- [CVE-2024-45626](https://insights.sbomify.com/CVE-2024-45626/): Apache James: denial of service through JMAP HTML to text conversion (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-7611 and fix it if it is affected.

What it is: CVE-2015-7611 is a high-severity command injection vulnerability in n/a, published on 7 Jun 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-7611 exists.

Affected packages and fixed versions:
- org.apache.james:james-server (Maven): affected all versions; fixed in 2.3.2.1
- org.apache.james:james-server (Maven): affected all versions; fixed in 2.3.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-7611/ (Markdown: https://insights.sbomify.com/CVE-2015-7611/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-7611
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-7611
- OSV: https://osv.dev/vulnerability/CVE-2015-7611

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-7611/
Summaries are generated and may contain mistakes; the official description above is the record.
