CVE-2015-7672 Centreon Cross-site Scripting Vulnerability
An attacker can inject malicious scripts into Centreon web interface, potentially stealing user sessions or executing code in victim browsers.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2015-7672?
CVE-2015-7672 is a medium-severity cross-site scripting vulnerability in Centreon Centreon, published on 7 Sep 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in Centreon 2.6.1 (fixed in Centreon 18.10.0 and Centreon web 2.8.27).
Weakness: CWE-79
Which versions are affected by CVE-2015-7672?
2 open source packages ship an affected version, including centreon/centreon. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
centreon/centreon Packagist | All versions | 2.8.27 |
centreon/centreon Packagist | All versions | 2.8.27 |
Products include Centreon Centreon.
How do I fix CVE-2015-7672?
Upgrade centreon/centreon to 2.8.27 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2015-7672 being exploited?
There is no known exploitation of CVE-2015-7672 in the wild and no public exploit code.
Other vulnerabilities in Centreon Centreon
Sources
Also known as GHSA-8w3f-236q-53m4.