# CVE-2015-7695: Zend Framework SQL injection vector using null byte for PDO

> Remote attackers can execute arbitrary SQL commands via crafted queries due to null byte filtering issues in Zend Framework PDO adapters.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jun 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DLA-326-1, GHSA-2hvh-c5c2-vj85, UBUNTU-CVE-2015-7695

## What is CVE-2015-7695?

CVE-2015-7695 is a critical SQL injection vulnerability in Debian Debian Linux, published on 7 Jun 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The PDO adapters in Zend Framework before 1.12.16 do not filer null bytes in SQL statements, which allows remote attackers to execute arbitrary SQL commands via a crafted query.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2015-7695?

2 open source packages ship an affected version, including zendframework/zendframework1. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zendframework/zendframework1` | Packagist | All versions | 1.12.16 |
| `zendframework/zendframework1` | Packagist | All versions | 1.12.16 |

Products: Debian Debian Linux, Zend Zend Framework.

## How do I fix CVE-2015-7695?

Upgrade zendframework/zendframework1 to 1.12.16 or later.

## Is CVE-2015-7695 being exploited?

There is no known exploitation of CVE-2015-7695 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-7695 and fix it if it is affected.

What it is: CVE-2015-7695 is a critical SQL injection vulnerability in Debian Debian Linux, published on 7 Jun 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-7695 in the wild and no public exploit code.

Affected packages and fixed versions:
- zendframework/zendframework1 (Packagist): affected all versions; fixed in 1.12.16
- zendframework/zendframework1 (Packagist): affected all versions; fixed in 1.12.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-7695/ (Markdown: https://insights.sbomify.com/CVE-2015-7695/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-7695
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-7695
- OSV: https://osv.dev/vulnerability/CVE-2015-7695

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-7695/
Summaries are generated and may contain mistakes; the official description above is the record.
