CVE-2015-7713 OpenStack Compute (Nova) allows remote attackers to bypass intended restriction

Medium 5.0 Published Updated

Remote attackers can bypass security group restrictions in OpenStack Compute by leveraging running instances, requiring an upgrade to fix.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2015-7713?

CVE-2015-7713 is a medium-severity vulnerability in n/a, published on 29 Oct 2015. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

OpenStack Compute (Nova) before 2014.2.4 (juno) and 2015.1.x before 2015.1.2 (kilo) do not properly apply security group changes, which allows remote attackers to bypass intended restriction by leveraging an instance that was running when the change was made.

Weakness: CWE-254

Which versions are affected by CVE-2015-7713?

5 open source packages ship an affected version, including nova. It affects 1 product.

PackageAffectedFixed in
nova PyPIAll versions2014.2.4, 2015.1.2
nova PyPIAll versions2014.2.4
nova PyPIAll versions2014.2.4
nova PyPIFrom 2015.1.02015.1.2
nova PyPIFrom 2015.1.02015.1.2
Linux distribution packages (35)
openstack-nova Red Hat:openstack:5::el7All versions0:2014.1.5-9.el7ost
openstack-nova-api Red Hat:openstack:5::el7All versions0:2014.1.5-9.el7ost
openstack-nova-cells Red Hat:openstack:5::el7All versions0:2014.1.5-9.el7ost
openstack-nova-cert Red Hat:openstack:5::el7All versions0:2014.1.5-9.el7ost
openstack-nova-common Red Hat:openstack:5::el7All versions0:2014.1.5-9.el7ost
openstack-nova-compute Red Hat:openstack:5::el7All versions0:2014.1.5-9.el7ost
openstack-nova-conductor Red Hat:openstack:5::el7All versions0:2014.1.5-9.el7ost
openstack-nova-console Red Hat:openstack:5::el7All versions0:2014.1.5-9.el7ost
openstack-nova-doc Red Hat:openstack:5::el7All versions0:2014.1.5-9.el7ost
openstack-nova-network Red Hat:openstack:5::el7All versions0:2014.1.5-9.el7ost
openstack-nova-novncproxy Red Hat:openstack:5::el7All versions0:2014.1.5-9.el7ost
openstack-nova-objectstore Red Hat:openstack:5::el7All versions0:2014.1.5-9.el7ost
openstack-nova-scheduler Red Hat:openstack:5::el7All versions0:2014.1.5-9.el7ost
openstack-nova-serialproxy Red Hat:openstack:5::el7All versions0:2014.1.5-9.el7ost
python-nova Red Hat:openstack:5::el7All versions0:2014.1.5-9.el7ost
openstack-nova Red Hat:openstack:6::el7All versions0:2014.2.3-42.el7ost
openstack-nova-api Red Hat:openstack:6::el7All versions0:2014.2.3-42.el7ost
openstack-nova-cells Red Hat:openstack:6::el7All versions0:2014.2.3-42.el7ost
openstack-nova-cert Red Hat:openstack:6::el7All versions0:2014.2.3-42.el7ost
openstack-nova-common Red Hat:openstack:6::el7All versions0:2014.2.3-42.el7ost
openstack-nova-compute Red Hat:openstack:6::el7All versions0:2014.2.3-42.el7ost
openstack-nova-conductor Red Hat:openstack:6::el7All versions0:2014.2.3-42.el7ost
openstack-nova-console Red Hat:openstack:6::el7All versions0:2014.2.3-42.el7ost
openstack-nova-doc Red Hat:openstack:6::el7All versions0:2014.2.3-42.el7ost
openstack-nova-network Red Hat:openstack:6::el7All versions0:2014.2.3-42.el7ost
openstack-nova-novncproxy Red Hat:openstack:6::el7All versions0:2014.2.3-42.el7ost
openstack-nova-objectstore Red Hat:openstack:6::el7All versions0:2014.2.3-42.el7ost
openstack-nova-scheduler Red Hat:openstack:6::el7All versions0:2014.2.3-42.el7ost
openstack-nova-serialproxy Red Hat:openstack:6::el7All versions0:2014.2.3-42.el7ost
python-nova Red Hat:openstack:6::el7All versions0:2014.2.3-42.el7ost
openstack-nova Red Hat:openstack:7::el7All versions0:2015.1.2-7.el7ost
openstack-nova-api Red Hat:openstack:7::el7All versions0:2015.1.2-7.el7ost
openstack-nova-cells Red Hat:openstack:7::el7All versions0:2015.1.2-7.el7ost
openstack-nova-cert Red Hat:openstack:7::el7All versions0:2015.1.2-7.el7ost
openstack-nova-common Red Hat:openstack:7::el7All versions0:2015.1.2-7.el7ost

Products include Openstack Nova.

How do I fix CVE-2015-7713?

Upgrade nova to a fixed version for your release line: 2014.2.4 or 2015.1.2.

Is CVE-2015-7713 being exploited?

There is no known exploitation of CVE-2015-7713 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2015-7713, GHSA-67rh-9p29-vrxr, PYSEC-2026-867, RHSA-2015:2673, RHSA-2015:2684, RHSA-2016:0013 and 1 more.

Is CVE-2015-7713 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free