{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2015-7758 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2015-7758 is a low-severity path traversal vulnerability in Opensuse Leap, published on 8 Jan 2016. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-7758 and fix it if it is affected.\n\nWhat it is: CVE-2015-7758 is a low-severity path traversal vulnerability in Opensuse Leap, published on 8 Jan 2016. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-7758 in the wild and no public exploit code.\n\nAffected product: Opensuse Leap. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-7758/ (Markdown: https://insights.sbomify.com/CVE-2015-7758/index.md)","id":"CVE-2015-7758","markdown":"https://insights.sbomify.com/CVE-2015-7758/index.md","name":"CVE-2015-7758","record":{"aliases":["DEBIAN-CVE-2015-7758","GHSA-r6gw-xg73-f977","UBUNTU-CVE-2015-7758","openSUSE-SU-2024:10107-1"],"analysis":{"component_type":"desktop_application","fix_type":"patch","impacts":["data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"LaTeX editor","requires_auth":"low_privilege","summary":"Local attackers can overwrite arbitrary files via symlink attacks on temporary files in Gummi, potentially compromising system integrity.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"gummi","vendor":"gummi_project"},{"product":"leap","vendor":"opensuse"},{"product":"opensuse","vendor":"opensuse"}],"cvss":{"score":3.3,"severity":"low","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-59","name":"Improper Link Resolution Before File Access"}],"description":"Gummi 0.6.5 allows local users to write to arbitrary files via a symlink attack on a temporary dot file that uses the name of an existing file and a (1) .aux, (2) .log, (3) .out, (4) .pdf, or (5) .toc extension for the file name, as demonstrated by .thesis.tex.aux.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Path traversal in n/a","id":"CVE-2015-7758","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"opensuse:leap","products":["opensuse:leap","opensuse:opensuse"],"type":"path_traversal","year":"2015"},"n_packages":1,"n_references":7,"next":{"headline":"Denial of service in n/a","id":"CVE-2015-7759"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.7.4.3-2.6"],"introduced":["0"],"last_affected":[],"package":"gummi","purl":"pkg:rpm/opensuse/gummi\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10107-1"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2015-7757"},"products":["n/a"],"published":"2016-01-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Local attackers can overwrite arbitrary files via symlink attacks on temporary files in Gummi, potentially compromising system integrity.","url":"https://insights.sbomify.com/CVE-2015-7758/"}