# CVE-2015-7809: Twig remote code execution in templates

> Remote attackers can execute arbitrary code in Twig templates when Sandbox mode is enabled, requiring an upgrade to secure the application.

- **Severity:** Medium 6.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Nov 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DSA-3343-1, GHSA-xw83-pwrm-9j74

## What is CVE-2015-7809?

CVE-2015-7809 is a medium-severity code injection vulnerability in n/a, published on 6 Nov 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The displayBlock function Template.php in Sensio Labs Twig before 1.20.0, when Sandbox mode is enabled, allows remote attackers to execute arbitrary code via the _self variable in a template.

Weakness: CWE-264

## Which versions are affected by CVE-2015-7809?

2 open source packages ship an affected version, including twig/twig. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `twig/twig` | Packagist | All versions | 1.20.0 |
| `twig/twig` | Packagist | All versions | 1.20.0 |

Products: Symfony Twig.

## How do I fix CVE-2015-7809?

Upgrade twig/twig to 1.20.0 or later.

## Is CVE-2015-7809 being exploited?

There is no known exploitation of CVE-2015-7809 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-13818](https://insights.sbomify.com/CVE-2018-13818/): Code injection in n/a (critical 9.8)
- [CVE-2026-46633](https://insights.sbomify.com/CVE-2026-46633/): Twig: PHP code injection via `{% use %}` template name (high 8.7)
- [CVE-2026-46640](https://insights.sbomify.com/CVE-2026-46640/): Twig: Arbitrary PHP code execution via `_self.(<string>)` macro-reference compilation (high 8.7)
- [CVE-2026-24425](https://insights.sbomify.com/CVE-2026-24425/): Twig 2.16.x & 3.9.0-3.25.x Sandbox Bypass via SourcePolicyInterface (high 8.7)
- [CVE-2024-45411](https://insights.sbomify.com/CVE-2024-45411/): Twig has a possible sandbox bypass (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-7809 and fix it if it is affected.

What it is: CVE-2015-7809 is a medium-severity code injection vulnerability in n/a, published on 6 Nov 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-7809 in the wild and no public exploit code.

Affected packages and fixed versions:
- twig/twig (Packagist): affected all versions; fixed in 1.20.0
- twig/twig (Packagist): affected all versions; fixed in 1.20.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-7809/ (Markdown: https://insights.sbomify.com/CVE-2015-7809/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-7809
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-7809
- OSV: https://osv.dev/vulnerability/CVE-2015-7809

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-7809/
Summaries are generated and may contain mistakes; the official description above is the record.
