CVE-2015-7873 phpMyAdmin allows remote attackers to spoof content via the url parameter
Remote attackers can spoof content via the url parameter in phpMyAdmin's redirection feature, requiring user interaction to exploit.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2015-7873?
CVE-2015-7873 is a medium-severity vulnerability in Phpmyadmin Phpmyadmin, published on 28 Oct 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
The redirection feature in url.php in phpMyAdmin 4.4.x before 4.4.15.1 and 4.5.x before 4.5.1 allows remote attackers to spoof content via the url parameter.
Weakness: CWE-254
Which versions are affected by CVE-2015-7873?
4 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.4.0 | 4.4.15.1 |
phpmyadmin/phpmyadmin Packagist | From 4.4.0 | 4.4.15.1 |
phpmyadmin/phpmyadmin Packagist | From 4.5.0 | 4.5.1 |
phpmyadmin/phpmyadmin Packagist | From 4.5.0 | 4.5.1 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2015-7873?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.4.15.1 or 4.5.1.
Is CVE-2015-7873 being exploited?
There is no known exploitation of CVE-2015-7873 in the wild and no public exploit code.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as DEBIAN-CVE-2015-7873, GHSA-5pmg-qh2c-7j24, MGASA-2015-0419.