{"answers":{"affected":"4 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-7873 in the wild and no public exploit code.","fix":"Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.4.15.1 or 4.5.1.","what":"CVE-2015-7873 is a medium-severity vulnerability in Phpmyadmin Phpmyadmin, published on 28 Oct 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-7873 and fix it if it is affected.\n\nWhat it is: CVE-2015-7873 is a medium-severity vulnerability in Phpmyadmin Phpmyadmin, published on 28 Oct 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-7873 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.4.0; fixed in 4.4.15.1\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.4.0; fixed in 4.4.15.1\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.5.0; fixed in 4.5.1\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.5.0; fixed in 4.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-7873/ (Markdown: https://insights.sbomify.com/CVE-2015-7873/index.md)","id":"CVE-2015-7873","markdown":"https://insights.sbomify.com/CVE-2015-7873/index.md","name":"CVE-2015-7873","record":{"aliases":["DEBIAN-CVE-2015-7873","GHSA-5pmg-qh2c-7j24","MGASA-2015-0419"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"phpMyAdmin","requires_auth":"none","summary":"Remote attackers can spoof content via the url parameter in phpMyAdmin's redirection feature, requiring user interaction to exploit.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"phpmyadmin","vendor":"phpmyadmin"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-254","name":null}],"description":"The redirection feature in url.php in phpMyAdmin 4.4.x before 4.4.15.1 and 4.5.x before 4.5.1 allows remote attackers to spoof content via the url parameter.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpMyAdmin allows remote attackers to spoof content via the url parameter","id":"CVE-2015-7873","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyadmin:phpmyadmin","products":["phpmyadmin:phpmyadmin"],"type":"open_redirect","year":"2015"},"n_packages":4,"n_references":8,"next":{"headline":"Memory corruption in n/a","id":"CVE-2015-7874"},"packages":[{"ecosystem":"Packagist","fixed":["4.4.15.1"],"introduced":["4.4.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-5pmg-qh2c-7j24"},{"ecosystem":"Packagist","fixed":["4.4.15.1"],"introduced":["4.4.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-5pmg-qh2c-7j24"},{"ecosystem":"Packagist","fixed":["4.5.1"],"introduced":["4.5.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-5pmg-qh2c-7j24"},{"ecosystem":"Packagist","fixed":["4.5.1"],"introduced":["4.5.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-5pmg-qh2c-7j24"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2015-7872"},"products":["n/a"],"published":"2015-10-28","related":[{"cvss_score":10,"headline":"Misconfiguration in n/a","id":"CVE-2008-7251","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"phpMyAdmin unsafely handles temporary files","id":"CVE-2008-7252","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2007-0203","kev_date_added":null,"published":"2007-01-11"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2004-1147","kev_date_added":null,"published":"2004-12-15"},{"cvss_score":9.8,"headline":"phpmyadmin contains SQL Injection vulnerability","id":"CVE-2020-22452","kev_date_added":null,"published":"2023-01-26"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-11768","kev_date_added":null,"published":"2019-06-05"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-6798","kev_date_added":null,"published":"2019-01-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can spoof content via the url parameter in phpMyAdmin's redirection feature, requiring user interaction to exploit.","url":"https://insights.sbomify.com/CVE-2015-7873/"}