{"answers":{"affected":"2 open source packages ship an affected version, including openpgp. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-8013 in the wild and no public exploit code.","fix":"Upgrade openpgp to 1.3.0 or later.","what":"CVE-2015-8013 is a high-severity vulnerability in n/a, published on 25 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-8013 and fix it if it is affected.\n\nWhat it is: CVE-2015-8013 is a high-severity vulnerability in n/a, published on 25 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-8013 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openpgp (npm): affected all versions; fixed in 1.3.0\n- openpgp (npm): affected all versions; fixed in 1.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-8013/ (Markdown: https://insights.sbomify.com/CVE-2015-8013/index.md)","id":"CVE-2015-8013","markdown":"https://insights.sbomify.com/CVE-2015-8013/index.md","name":"CVE-2015-8013","record":{"aliases":["GHSA-qmvq-f3fj-m3wg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript PGP library","requires_auth":"none","summary":"Attackers can bypass authentication in OpenPGP.js by crafting PGP keys that allow decryption of arbitrary messages without the correct passphrase.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"openpgpjs","vendor":"openpgpjs"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-310","name":null}],"description":"s2k.js in OpenPGP.js will decrypt arbitrary messages regardless of passphrase for crafted PGP keys which allows remote attackers to bypass authentication if message decryption is used as an authentication mechanism via a crafted symmetrically encrypted PGP message.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenPGP 1.2.0 and earlier decrypts arbitrary messages","id":"CVE-2015-8013","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2015"},"n_packages":2,"n_references":3,"next":{"headline":"Memory corruption in n/a","id":"CVE-2015-8019"},"packages":[{"ecosystem":"npm","fixed":["1.3.0"],"introduced":["0"],"last_affected":[],"package":"openpgp","purl":null,"source":"GHSA-qmvq-f3fj-m3wg"},{"ecosystem":"npm","fixed":["1.3.0"],"introduced":["0"],"last_affected":[],"package":"openpgp","purl":"pkg:npm/openpgp","source":"GHSA-qmvq-f3fj-m3wg"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2015-8012"},"products":["n/a"],"published":"2017-07-25","related":[{"cvss_score":7.5,"headline":"Message Signature Bypass in openpgp","id":"CVE-2019-9153","kev_date_added":null,"published":"2019-08-22"},{"cvss_score":7.5,"headline":"Improper Key Verification in openpgp","id":"CVE-2019-9154","kev_date_added":null,"published":"2019-08-22"},{"cvss_score":5.9,"headline":"Invalid Curve Attack in openpgp","id":"CVE-2019-9155","kev_date_added":null,"published":"2019-08-22"},{"cvss_score":4.3,"headline":"Cleartext Signed Message Signature Spoofing in openpgpjs","id":"CVE-2023-41037","kev_date_added":null,"published":"2023-08-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can bypass authentication in OpenPGP.js by crafting PGP keys that allow decryption of arbitrary messages without the correct passphrase.","url":"https://insights.sbomify.com/CVE-2015-8013/"}