# CVE-2015-8013: OpenPGP 1.2.0 and earlier decrypts arbitrary messages

> Attackers can bypass authentication in OpenPGP.js by crafting PGP keys that allow decryption of arbitrary messages without the correct passphrase.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jul 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-qmvq-f3fj-m3wg

## What is CVE-2015-8013?

CVE-2015-8013 is a high-severity vulnerability in n/a, published on 25 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

s2k.js in OpenPGP.js will decrypt arbitrary messages regardless of passphrase for crafted PGP keys which allows remote attackers to bypass authentication if message decryption is used as an authentication mechanism via a crafted symmetrically encrypted PGP message.

Weakness: CWE-310

## Which versions are affected by CVE-2015-8013?

2 open source packages ship an affected version, including openpgp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openpgp` | npm | All versions | 1.3.0 |
| `openpgp` | npm | All versions | 1.3.0 |

Products: Openpgpjs Openpgpjs.

## How do I fix CVE-2015-8013?

Upgrade openpgp to 1.3.0 or later.

## Is CVE-2015-8013 being exploited?

There is no known exploitation of CVE-2015-8013 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-9153](https://insights.sbomify.com/CVE-2019-9153/): Message Signature Bypass in openpgp (high 7.5)
- [CVE-2019-9154](https://insights.sbomify.com/CVE-2019-9154/): Improper Key Verification in openpgp (high 7.5)
- [CVE-2019-9155](https://insights.sbomify.com/CVE-2019-9155/): Invalid Curve Attack in openpgp (medium 5.9)
- [CVE-2023-41037](https://insights.sbomify.com/CVE-2023-41037/): Cleartext Signed Message Signature Spoofing in openpgpjs (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-8013 and fix it if it is affected.

What it is: CVE-2015-8013 is a high-severity vulnerability in n/a, published on 25 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-8013 in the wild and no public exploit code.

Affected packages and fixed versions:
- openpgp (npm): affected all versions; fixed in 1.3.0
- openpgp (npm): affected all versions; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-8013/ (Markdown: https://insights.sbomify.com/CVE-2015-8013/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-8013
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-8013
- OSV: https://osv.dev/vulnerability/CVE-2015-8013

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-8013/
Summaries are generated and may contain mistakes; the official description above is the record.
