# CVE-2015-8103: Jenkins CLI Deserialization of Untrusted Data vulnerability

> Remote attackers can execute arbitrary code on Jenkins servers by sending crafted serialized Java objects via the CLI subsystem.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Nov 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-wfw7-6632-xcv2, MGASA-2016-0137

## What is CVE-2015-8103?

CVE-2015-8103 is a critical unsafe deserialization vulnerability in Jenkins Jenkins, published on 25 Nov 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Jenkins CLI subsystem in Jenkins before 1.638 and LTS before 1.625.2 allows remote attackers to execute arbitrary code via a crafted serialized Java object, related to a problematic webapps/ROOT/WEB-INF/lib/commons-collections-*.jar file and the "Groovy variant in 'ysoserial'".

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2015-8103?

4 open source packages ship an affected version, including org.jenkins-ci.main:cli. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:cli` | Maven | All versions | 1.625.2 |
| `org.jenkins-ci.main:cli` | Maven | All versions | 1.625.2 |
| `org.jenkins-ci.main:cli` | Maven | From 1.626 | 1.638 |
| `org.jenkins-ci.main:cli` | Maven | From 1.626 | 1.638 |

Products: Jenkins Jenkins, Redhat Openshift Container Platform.

## How do I fix CVE-2015-8103?

Upgrade org.jenkins-ci.main:cli to a fixed version for your release line: 1.625.2 or 1.638.

## Is CVE-2015-8103 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-8103 exists.

Public exploit code:

- OpenNMS Java Object Unserialization Remote Code Execution (metasploit)
- Jenkins CLI RMI Java Deserialization Vulnerability (metasploit)
- Jenkins CLI - RMI Java Deserialization (Metasploit) (exploitdb)
- cve-2015-8103 (github_poc): https://github.com/cved-sources/cve-2015-8103
- https://github.com/r00t4dm/Jenkins-CVE-2015-8103 (github_poc): https://github.com/r00t4dm/Jenkins-CVE-2015-8103
- Jenkins-CI Unauthenticated Script-Console Scanner (metasploit)

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-8103 and fix it if it is affected.

What it is: CVE-2015-8103 is a critical unsafe deserialization vulnerability in Jenkins Jenkins, published on 25 Nov 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-8103 exists.

Affected packages and fixed versions:
- org.jenkins-ci.main:cli (Maven): affected all versions; fixed in 1.625.2
- org.jenkins-ci.main:cli (Maven): affected all versions; fixed in 1.625.2
- org.jenkins-ci.main:cli (Maven): affected from 1.626; fixed in 1.638
- org.jenkins-ci.main:cli (Maven): affected from 1.626; fixed in 1.638

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-8103/ (Markdown: https://insights.sbomify.com/CVE-2015-8103/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-8103
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-8103
- OSV: https://osv.dev/vulnerability/CVE-2015-8103

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-8103/
Summaries are generated and may contain mistakes; the official description above is the record.
