CVE-2015-8125 Symfony Vulnerable to Timing Attack
Remote attackers can bypass security features like RememberMe and CSRF protection via timing attacks in the Symfony Security and Form components.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-8125?
CVE-2015-8125 is a high-severity vulnerability in Sensiolabs Symfony, published on 7 Dec 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Symfony 2.3.x before 2.3.35, 2.6.x before 2.6.12, and 2.7.x before 2.7.7 might allow remote attackers to have unspecified impact via a timing attack involving the (1) Symfony/Component/Security/Http/RememberMe/PersistentTokenBasedRememberMeServices or (2) Symfony/Component/Security/Http/Firewall/DigestAuthenticationListener class in the Symfony Security Component, or (3) legacy CSRF implementation from the Symfony/Component/Form/Extension/Csrf/CsrfProvider/DefaultCsrfProvider class in the Symfony Form component.
Which versions are affected by CVE-2015-8125?
22 open source packages ship an affected version, including symfony/form, symfony/security and symfony/security-http. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
symfony/form Packagist | From 2.3.0 | 2.3.35 |
symfony/form Packagist | From 2.3.0 | 2.3.35 |
symfony/form Packagist | From 2.4.0 | 2.6.12 |
symfony/form Packagist | From 2.4.0 | 2.6.12 |
symfony/form Packagist | From 2.7.0 | 2.7.7 |
symfony/form Packagist | From 2.7.0 | 2.7.7 |
16 more packages
symfony/security Packagist | From 2.3.0 | 2.3.35 |
symfony/security Packagist | From 2.3.0 | 2.3.35 |
symfony/security Packagist | From 2.4.0 | 2.6.12 |
symfony/security Packagist | From 2.4.0 | 2.6.12 |
symfony/security Packagist | From 2.7.0 | 2.7.7 |
symfony/security Packagist | From 2.7.0 | 2.7.7 |
symfony/security-http Packagist | From 2.4.0 | 2.6.12 |
symfony/security-http Packagist | From 2.4.0 | 2.6.12 |
symfony/security-http Packagist | From 2.7.0 | 2.7.7 |
symfony/security-http Packagist | From 2.7.0 | 2.7.7 |
symfony/symfony Packagist | From 2.3.0 | 2.3.35 |
symfony/symfony Packagist | From 2.3.0 | 2.3.35 |
symfony/symfony Packagist | From 2.4.0 | 2.6.12 |
symfony/symfony Packagist | From 2.4.0 | 2.6.12 |
symfony/symfony Packagist | From 2.7.0 | 2.7.7 |
symfony/symfony Packagist | From 2.7.0 | 2.7.7 |
Products include Sensiolabs Symfony.
How do I fix CVE-2015-8125?
Upgrade symfony/form to a fixed version for your release line: 2.3.35, 2.6.12 or 2.7.7.
Is CVE-2015-8125 being exploited?
There is no known exploitation of CVE-2015-8125 in the wild and no public exploit code.
Other vulnerabilities in Sensiolabs Symfony
Sources
Also known as DEBIAN-CVE-2015-8125, GHSA-g97c-jfx6-xvxh.