# CVE-2015-8125: Symfony Vulnerable to Timing Attack

> Remote attackers can bypass security features like RememberMe and CSRF protection via timing attacks in the Symfony Security and Form components.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Dec 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-8125, GHSA-g97c-jfx6-xvxh

## What is CVE-2015-8125?

CVE-2015-8125 is a high-severity vulnerability in Sensiolabs Symfony, published on 7 Dec 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Symfony 2.3.x before 2.3.35, 2.6.x before 2.6.12, and 2.7.x before 2.7.7 might allow remote attackers to have unspecified impact via a timing attack involving the (1) Symfony/Component/Security/Http/RememberMe/PersistentTokenBasedRememberMeServices or (2) Symfony/Component/Security/Http/Firewall/DigestAuthenticationListener class in the Symfony Security Component, or (3) legacy CSRF implementation from the Symfony/Component/Form/Extension/Csrf/CsrfProvider/DefaultCsrfProvider class in the Symfony Form component.

## Which versions are affected by CVE-2015-8125?

22 open source packages ship an affected version, including symfony/form, symfony/security and symfony/security-http. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/form` | Packagist | From 2.3.0 | 2.3.35 |
| `symfony/form` | Packagist | From 2.3.0 | 2.3.35 |
| `symfony/form` | Packagist | From 2.4.0 | 2.6.12 |
| `symfony/form` | Packagist | From 2.4.0 | 2.6.12 |
| `symfony/form` | Packagist | From 2.7.0 | 2.7.7 |
| `symfony/form` | Packagist | From 2.7.0 | 2.7.7 |
| `symfony/security` | Packagist | From 2.3.0 | 2.3.35 |
| `symfony/security` | Packagist | From 2.3.0 | 2.3.35 |
| `symfony/security` | Packagist | From 2.4.0 | 2.6.12 |
| `symfony/security` | Packagist | From 2.4.0 | 2.6.12 |
| `symfony/security` | Packagist | From 2.7.0 | 2.7.7 |
| `symfony/security` | Packagist | From 2.7.0 | 2.7.7 |
| `symfony/security-http` | Packagist | From 2.4.0 | 2.6.12 |
| `symfony/security-http` | Packagist | From 2.4.0 | 2.6.12 |
| `symfony/security-http` | Packagist | From 2.7.0 | 2.7.7 |
| `symfony/security-http` | Packagist | From 2.7.0 | 2.7.7 |
| `symfony/symfony` | Packagist | From 2.3.0 | 2.3.35 |
| `symfony/symfony` | Packagist | From 2.3.0 | 2.3.35 |
| `symfony/symfony` | Packagist | From 2.4.0 | 2.6.12 |
| `symfony/symfony` | Packagist | From 2.4.0 | 2.6.12 |
| `symfony/symfony` | Packagist | From 2.7.0 | 2.7.7 |
| `symfony/symfony` | Packagist | From 2.7.0 | 2.7.7 |

Products: Sensiolabs Symfony.

## How do I fix CVE-2015-8125?

Upgrade symfony/form to a fixed version for your release line: 2.3.35, 2.6.12 or 2.7.7.

## Is CVE-2015-8125 being exploited?

There is no known exploitation of CVE-2015-8125 in the wild and no public exploit code.

## Other vulnerabilities in Sensiolabs Symfony

- [CVE-2019-11325](https://insights.sbomify.com/CVE-2019-11325/): Improper Input Validation in Symfony (critical 9.8)
- [CVE-2017-11365](https://insights.sbomify.com/CVE-2017-11365/): Symfony Incorrect Access Control (critical 9.8)
- [CVE-2019-10913](https://insights.sbomify.com/CVE-2019-10913/): Invalid HTTP method overrides allow possible XSS or other attacks in Symfony (critical 9.8)
- [CVE-2018-11407](https://insights.sbomify.com/CVE-2018-11407/): Symfony Authentication Bypass (critical 9.8)
- [CVE-2016-2403](https://insights.sbomify.com/CVE-2016-2403/): Symfony Authentication Bypass (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-8125 and fix it if it is affected.

What it is: CVE-2015-8125 is a high-severity vulnerability in Sensiolabs Symfony, published on 7 Dec 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-8125 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/form (Packagist): affected from 2.3.0; fixed in 2.3.35
- symfony/form (Packagist): affected from 2.3.0; fixed in 2.3.35
- symfony/form (Packagist): affected from 2.4.0; fixed in 2.6.12
- symfony/form (Packagist): affected from 2.4.0; fixed in 2.6.12
- symfony/form (Packagist): affected from 2.7.0; fixed in 2.7.7
- symfony/form (Packagist): affected from 2.7.0; fixed in 2.7.7
- symfony/security (Packagist): affected from 2.3.0; fixed in 2.3.35
- symfony/security (Packagist): affected from 2.3.0; fixed in 2.3.35
- symfony/security (Packagist): affected from 2.4.0; fixed in 2.6.12
- symfony/security (Packagist): affected from 2.4.0; fixed in 2.6.12
- symfony/security (Packagist): affected from 2.7.0; fixed in 2.7.7
- symfony/security (Packagist): affected from 2.7.0; fixed in 2.7.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-8125/ (Markdown: https://insights.sbomify.com/CVE-2015-8125/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-8125
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-8125
- OSV: https://osv.dev/vulnerability/CVE-2015-8125

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-8125/
Summaries are generated and may contain mistakes; the official description above is the record.
