# CVE-2015-8213: Django settings leak in date template filter

> Remote attackers can obtain sensitive application secrets like SECRET_KEY by manipulating date/time format settings in Django.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Dec 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-8213, DLA-349-1, DSA-3404-1, GHSA-6wcr-wcqm-3mfh, MGASA-2015-0463, PYSEC-2015-11, RHSA-2016:0129, RHSA-2016:0156, RHSA-2016:0157, RHSA-2016:0158, RHSA-2016:0360, SUSE-SU-2015:2327-1, SUSE-SU-2016:0040-1, UBUNTU-CVE-2015-8213, USN-2816-1

## What is CVE-2015-8213?

CVE-2015-8213 is a medium-severity vulnerability in Djangoproject Django, published on 7 Dec 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The get_format function in utils/formats.py in Django before 1.7.x before 1.7.11, 1.8.x before 1.8.7, and 1.9.x before 1.9rc2 might allow remote attackers to obtain sensitive application secrets via a settings key in place of a date/time format setting, as demonstrated by SECRET_KEY.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2015-8213?

7 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | PyPI | All versions | 1.7.11, 1.8.7, 1.9rc2 |
| `django` | PyPI | From 1.7 | 1.7.11 |
| `django` | PyPI | From 1.8a1 | 1.8.7 |
| `django` | PyPI | From 1.9a1 | 1.9rc2 |
| `Django` | PyPI | From 1.7 | 1.7.11 |
| `Django` | PyPI | From 1.8a1 | 1.8.7 |
| `Django` | PyPI | From 1.9a1 | 1.9rc2 |
| `python-django` | Red Hat:openstack-optools:7::el7 | All versions | 0:1.6.11-4.el7ost |
| `python-django-bash-completion` | Red Hat:openstack-optools:7::el7 | All versions | 0:1.6.11-4.el7ost |
| `python-django` | Red Hat:openstack:5::el6 | All versions | 0:1.6.11-4.el6ost |
| `python-django-bash-completion` | Red Hat:openstack:5::el6 | All versions | 0:1.6.11-4.el6ost |
| `python-django-doc` | Red Hat:openstack:5::el6 | All versions | 0:1.6.11-4.el6ost |
| `python-django` | Red Hat:openstack:5::el7 | All versions | 0:1.6.11-4.el7ost |
| `python-django-bash-completion` | Red Hat:openstack:5::el7 | All versions | 0:1.6.11-4.el7ost |
| `python-django-doc` | Red Hat:openstack:5::el7 | All versions | 0:1.6.11-4.el7ost |
| `python-django` | Red Hat:openstack:6::el7 | All versions | 0:1.6.11-4.el7ost |
| `python-django-bash-completion` | Red Hat:openstack:6::el7 | All versions | 0:1.6.11-4.el7ost |
| `python-django-doc` | Red Hat:openstack:6::el7 | All versions | 0:1.6.11-4.el7ost |
| `python-django` | Red Hat:openstack:7::el7 | All versions | 0:1.8.7-1.el7 |
| `python-django-bash-completion` | Red Hat:openstack:7::el7 | All versions | 0:1.8.7-1.el7 |
| `python-django-doc` | Red Hat:openstack:7::el7 | All versions | 0:1.8.7-1.el7 |
| `python-Django` | SUSE:Enterprise Storage 1.0 | All versions | 1.6.11-11.1 |
| `python-Django` | SUSE:OpenStack Cloud 5 | All versions | 1.6.11-13.1 |

Products: Djangoproject Django.

## How do I fix CVE-2015-8213?

Upgrade django to a fixed version for your release line: 1.7.11, 1.8.7 or 1.9rc2.

## Is CVE-2015-8213 being exploited?

There is no known exploitation of CVE-2015-8213 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-8213 and fix it if it is affected.

What it is: CVE-2015-8213 is a medium-severity vulnerability in Djangoproject Django, published on 7 Dec 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-8213 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (PyPI): affected all versions; fixed in 1.7.11, 1.8.7, 1.9rc2
- django (PyPI): affected from 1.7; fixed in 1.7.11
- django (PyPI): affected from 1.8a1; fixed in 1.8.7
- django (PyPI): affected from 1.9a1; fixed in 1.9rc2
- Django (PyPI): affected from 1.7; fixed in 1.7.11
- Django (PyPI): affected from 1.8a1; fixed in 1.8.7
- Django (PyPI): affected from 1.9a1; fixed in 1.9rc2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-8213/ (Markdown: https://insights.sbomify.com/CVE-2015-8213/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-8213
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-8213
- OSV: https://osv.dev/vulnerability/CVE-2015-8213

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-8213/
Summaries are generated and may contain mistakes; the official description above is the record.
