{"answers":{"affected":"2 open source packages ship an affected version, including devise. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-8314 in the wild and no public exploit code.","fix":"Upgrade devise to 3.5.4 or later.","what":"CVE-2015-8314 is a high-severity authentication bypass vulnerability in n/a, published on 12 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-8314 and fix it if it is affected.\n\nWhat it is: CVE-2015-8314 is a high-severity authentication bypass vulnerability in n/a, published on 12 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-8314 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- devise (RubyGems): affected all versions; fixed in 3.5.4\n- devise (RubyGems): affected all versions; fixed in 3.5.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-8314/ (Markdown: https://insights.sbomify.com/CVE-2015-8314/index.md)","id":"CVE-2015-8314","markdown":"https://insights.sbomify.com/CVE-2015-8314/index.md","name":"CVE-2015-8314","record":{"aliases":["DEBIAN-CVE-2015-8314","GHSA-746g-3gfp-hfhw"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby authentication gem","requires_auth":"none","summary":"Attackers can gain unauthorized persistent access to applications using the Devise gem due to improper handling of Remember Me cookies.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"devise","vendor":"heartcombo"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-312","name":"Cleartext Storage of Sensitive Information"}],"description":"The Devise gem before 3.5.4 for Ruby mishandles Remember Me cookies for sessions, which may allow an adversary to obtain unauthorized persistent application access.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Devise Gem for Ruby Unauthorized Access Using \"Remember Me\" Cookie","id":"CVE-2015-8314","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"auth_bypass","year":"2015"},"n_packages":2,"n_references":3,"next":{"headline":"Regular Expression Denial of Service in ms","id":"CVE-2015-8315"},"packages":[{"ecosystem":"RubyGems","fixed":["3.5.4"],"introduced":["0"],"last_affected":[],"package":"devise","purl":null,"source":"GHSA-746g-3gfp-hfhw"},{"ecosystem":"RubyGems","fixed":["3.5.4"],"introduced":["0"],"last_affected":[],"package":"devise","purl":"pkg:gem/devise","source":"GHSA-746g-3gfp-hfhw"}],"prev":{"headline":"Other in n/a","id":"CVE-2015-8313"},"products":["n/a"],"published":"2023-12-12","related":[{"cvss_score":6.1,"headline":"Devise: Open Redirect via Unvalidated `request.referrer` in Timeoutable Session Timeout Handler","id":"CVE-2026-40295","kev_date_added":null,"published":"2026-05-22"},{"cvss_score":6,"headline":"Devise has a confirmable \"change email\" race condition that permits user to confirm email they have no access to","id":"CVE-2026-32700","kev_date_added":null,"published":"2026-03-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-27","vendors":["n/a"]},"summary":"Attackers can gain unauthorized persistent access to applications using the Devise gem due to improper handling of Remember Me cookies.","url":"https://insights.sbomify.com/CVE-2015-8314/"}