# CVE-2015-8314: Devise Gem for Ruby Unauthorized Access Using "Remember Me" Cookie

> Attackers can gain unauthorized persistent access to applications using the Devise gem due to improper handling of Remember Me cookies.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Dec 2023
- **Updated:** 27 May 2025
- **Also known as:** DEBIAN-CVE-2015-8314, GHSA-746g-3gfp-hfhw

## What is CVE-2015-8314?

CVE-2015-8314 is a high-severity authentication bypass vulnerability in n/a, published on 12 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Devise gem before 3.5.4 for Ruby mishandles Remember Me cookies for sessions, which may allow an adversary to obtain unauthorized persistent application access.

Weakness: CWE-312 (Cleartext Storage of Sensitive Information)

## Which versions are affected by CVE-2015-8314?

2 open source packages ship an affected version, including devise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `devise` | RubyGems | All versions | 3.5.4 |
| `devise` | RubyGems | All versions | 3.5.4 |

Products: Heartcombo Devise.

## How do I fix CVE-2015-8314?

Upgrade devise to 3.5.4 or later.

## Is CVE-2015-8314 being exploited?

There is no known exploitation of CVE-2015-8314 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-40295](https://insights.sbomify.com/CVE-2026-40295/): Devise: Open Redirect via Unvalidated `request.referrer` in Timeoutable Session Timeout Handler (medium 6.1)
- [CVE-2026-32700](https://insights.sbomify.com/CVE-2026-32700/): Devise has a confirmable "change email" race condition that permits user to confirm email they have no access to (medium 6.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-8314 and fix it if it is affected.

What it is: CVE-2015-8314 is a high-severity authentication bypass vulnerability in n/a, published on 12 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-8314 in the wild and no public exploit code.

Affected packages and fixed versions:
- devise (RubyGems): affected all versions; fixed in 3.5.4
- devise (RubyGems): affected all versions; fixed in 3.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-8314/ (Markdown: https://insights.sbomify.com/CVE-2015-8314/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-8314
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-8314
- OSV: https://osv.dev/vulnerability/CVE-2015-8314

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-8314/
Summaries are generated and may contain mistakes; the official description above is the record.
