{"answers":{"affected":"2 open source packages ship an affected version, including ms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-8315 in the wild and no public exploit code.","fix":"Upgrade ms to 0.7.1 or later.","what":"CVE-2015-8315 is a high-severity denial of service vulnerability in n/a, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-8315 and fix it if it is affected.\n\nWhat it is: CVE-2015-8315 is a high-severity denial of service vulnerability in n/a, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-8315 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ms (npm): affected all versions; fixed in 0.7.1\n- ms (npm): affected all versions; fixed in 0.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-8315/ (Markdown: https://insights.sbomify.com/CVE-2015-8315/index.md)","id":"CVE-2015-8315","markdown":"https://insights.sbomify.com/CVE-2015-8315/index.md","name":"CVE-2015-8315","record":{"aliases":["GHSA-3fx5-fwvr-xrjg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js ms package","requires_auth":"none","summary":"Attackers can cause denial of service via CPU consumption using long version strings in the Node.js ms package.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ms","vendor":"vercel"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"The ms package before 0.7.1 for Node.js allows attackers to cause a denial of service (CPU consumption) via a long version string, aka a \"regular expression denial of service (ReDoS).\"","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial of Service in ms","id":"CVE-2015-8315","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2015"},"n_packages":2,"n_references":4,"next":{"headline":"Denial of service in n/a","id":"CVE-2015-8316"},"packages":[{"ecosystem":"npm","fixed":["0.7.1"],"introduced":["0"],"last_affected":[],"package":"ms","purl":null,"source":"GHSA-3fx5-fwvr-xrjg"},{"ecosystem":"npm","fixed":["0.7.1"],"introduced":["0"],"last_affected":[],"package":"ms","purl":"pkg:npm/ms","source":"GHSA-3fx5-fwvr-xrjg"}],"prev":{"headline":"Devise Gem for Ruby Unauthorized Access Using \"Remember Me\" Cookie","id":"CVE-2015-8314"},"products":["n/a"],"published":"2017-01-23","related":[{"cvss_score":4.3,"headline":"vercel ms index.js parse redos","id":"CVE-2017-20162","kev_date_added":null,"published":"2023-01-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can cause denial of service via CPU consumption using long version strings in the Node.js ms package.","url":"https://insights.sbomify.com/CVE-2015-8315/"}