# CVE-2015-8315: Regular Expression Denial of Service in ms

> Attackers can cause denial of service via CPU consumption using long version strings in the Node.js ms package.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jan 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-3fx5-fwvr-xrjg

## What is CVE-2015-8315?

CVE-2015-8315 is a high-severity denial of service vulnerability in n/a, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The ms package before 0.7.1 for Node.js allows attackers to cause a denial of service (CPU consumption) via a long version string, aka a "regular expression denial of service (ReDoS)."

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2015-8315?

2 open source packages ship an affected version, including ms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ms` | npm | All versions | 0.7.1 |
| `ms` | npm | All versions | 0.7.1 |

Products: Vercel Ms.

## How do I fix CVE-2015-8315?

Upgrade ms to 0.7.1 or later.

## Is CVE-2015-8315 being exploited?

There is no known exploitation of CVE-2015-8315 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-20162](https://insights.sbomify.com/CVE-2017-20162/): vercel ms index.js parse redos (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-8315 and fix it if it is affected.

What it is: CVE-2015-8315 is a high-severity denial of service vulnerability in n/a, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-8315 in the wild and no public exploit code.

Affected packages and fixed versions:
- ms (npm): affected all versions; fixed in 0.7.1
- ms (npm): affected all versions; fixed in 0.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-8315/ (Markdown: https://insights.sbomify.com/CVE-2015-8315/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-8315
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-8315
- OSV: https://osv.dev/vulnerability/CVE-2015-8315

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-8315/
Summaries are generated and may contain mistakes; the official description above is the record.
