# CVE-2015-8371: Composer allows cache poisoning from other projects built on the same host

> Attackers can poison the Composer cache to inject malicious code into server-side build processes on shared hosts.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Sep 2023
- **Updated:** 25 Sep 2024
- **Also known as:** DEBIAN-CVE-2015-8371, GHSA-725m-w832-q973

## What is CVE-2015-8371?

CVE-2015-8371 is a high-severity vulnerability in n/a, published on 21 Sep 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Composer before 2016-02-10 allows cache poisoning from other projects built on the same host. This results in attacker-controlled code entering a server-side build process. The issue occurs because of the way that dist packages are cached. The cache key is derived from the package name, the dist type, and certain other data from the package repository (which may simply be a commit hash, and thus can be found by an attacker). Versions through 1.0.0-alpha11 are affected, and 1.0.0 is unaffected.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2015-8371?

2 open source packages ship an affected version, including composer/composer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `composer/composer` | Packagist | All versions | 1.0.0 |
| `composer/composer` | Packagist | All versions | 1.0.0 |

Products: Getcomposer Composer.

## How do I fix CVE-2015-8371?

Upgrade composer/composer to 1.0.0 or later.

## Is CVE-2015-8371 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-8371 exists.

## Other vulnerabilities in n/a

- [CVE-2026-40261](https://insights.sbomify.com/CVE-2026-40261/): Composer has Command Injection via Malicious Perforce Reference (high 8.8)
- [CVE-2024-24821](https://insights.sbomify.com/CVE-2024-24821/): Code execution and possible privilege escalation via compromised InstalledVersions.php or installed.php in Composer (high 8.8)
- [CVE-2021-41116](https://insights.sbomify.com/CVE-2021-41116/): Command injection in composer on Windows (high 8.2)
- [CVE-2026-40176](https://insights.sbomify.com/CVE-2026-40176/): Composer is vulnerable to Command Injection via Malicious Perforce Repository (high 7.8)
- [CVE-2025-67746](https://insights.sbomify.com/CVE-2025-67746/): Composer vulnerable to ANSI sequence injection (low 1.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-8371 and fix it if it is affected.

What it is: CVE-2015-8371 is a high-severity vulnerability in n/a, published on 21 Sep 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2015-8371 exists.

Affected packages and fixed versions:
- composer/composer (Packagist): affected all versions; fixed in 1.0.0
- composer/composer (Packagist): affected all versions; fixed in 1.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-8371/ (Markdown: https://insights.sbomify.com/CVE-2015-8371/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-8371
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-8371
- OSV: https://osv.dev/vulnerability/CVE-2015-8371

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-8371/
Summaries are generated and may contain mistakes; the official description above is the record.
