# CVE-2015-8476: SMTP Injection in PHPMailer

> Attackers can inject arbitrary SMTP commands via CRLF sequences in email addresses or commands, potentially leading to code execution or security bypass.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Dec 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-8476, DLA-363-1, DSA-3416-1, GHSA-738m-f33v-qc2r, MGASA-2015-0484, UBUNTU-CVE-2015-8476

## What is CVE-2015-8476?

CVE-2015-8476 is a medium-severity command injection vulnerability in Debian Debian Linux, published on 16 Dec 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Multiple CRLF injection vulnerabilities in PHPMailer before 5.2.14 allow attackers to inject arbitrary SMTP commands via CRLF sequences in an (1) email address to the validateAddress function in class.phpmailer.php or (2) SMTP command to the sendCommand function in class.smtp.php, a different vulnerability than CVE-2012-0796.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2015-8476?

2 open source packages ship an affected version, including phpmailer/phpmailer. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmailer/phpmailer` | Packagist | From 5.0.0 | 5.2.14 |
| `phpmailer/phpmailer` | Packagist | From 5.0.0 | 5.2.14 |

Products: Debian Debian Linux, Phpmailer Project Phpmailer.

## How do I fix CVE-2015-8476?

Upgrade phpmailer/phpmailer to 5.2.14 or later.

## Is CVE-2015-8476 being exploited?

There is no known exploitation of CVE-2015-8476 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-8476 and fix it if it is affected.

What it is: CVE-2015-8476 is a medium-severity command injection vulnerability in Debian Debian Linux, published on 16 Dec 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-8476 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmailer/phpmailer (Packagist): affected from 5.0.0; fixed in 5.2.14
- phpmailer/phpmailer (Packagist): affected from 5.0.0; fixed in 5.2.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-8476/ (Markdown: https://insights.sbomify.com/CVE-2015-8476/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-8476
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-8476
- OSV: https://osv.dev/vulnerability/CVE-2015-8476

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-8476/
Summaries are generated and may contain mistakes; the official description above is the record.
