# CVE-2015-8557: Command Injection in Pygments

> Remote attackers can execute arbitrary commands via shell metacharacters in font names processed by the Pygments library.

- **Severity:** Critical 9.0 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-8557, DLA-369-1, DSA-3445-1, GHSA-fff8-4w9p-7v76, MGASA-2015-0478, PYSEC-2016-32, UBUNTU-CVE-2015-8557, USN-2862-1

## What is CVE-2015-8557?

CVE-2015-8557 is a critical command injection vulnerability in Canonical Ubuntu Linux, published on 8 Jan 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The FontManager._get_nix_font_path function in formatters/img.py in Pygments 1.2.2 through 2.0.2 allows remote attackers to execute arbitrary commands via shell metacharacters in a font name.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2015-8557?

3 open source packages ship an affected version, including pygments and Pygments. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pygments` | PyPI | From 1.2.2 | 2.1 |
| `pygments` | PyPI | From 1.2.2 | 2.1 |
| `Pygments` | PyPI | From 1.2.2 | 2.1 |

Products: Canonical Ubuntu Linux, Pygments Pygments.

## How do I fix CVE-2015-8557?

Upgrade pygments to 2.1 or later.

## Is CVE-2015-8557 being exploited?

There is no known exploitation of CVE-2015-8557 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-8557 and fix it if it is affected.

What it is: CVE-2015-8557 is a critical command injection vulnerability in Canonical Ubuntu Linux, published on 8 Jan 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-8557 in the wild and no public exploit code.

Affected packages and fixed versions:
- pygments (PyPI): affected from 1.2.2; fixed in 2.1
- pygments (PyPI): affected from 1.2.2; fixed in 2.1
- Pygments (PyPI): affected from 1.2.2; fixed in 2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-8557/ (Markdown: https://insights.sbomify.com/CVE-2015-8557/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-8557
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-8557
- OSV: https://osv.dev/vulnerability/CVE-2015-8557

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-8557/
Summaries are generated and may contain mistakes; the official description above is the record.
