{"answers":{"affected":"2 open source packages ship an affected version, including joomla/session. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-8566 in the wild and no public exploit code.","fix":"Upgrade joomla/session to 1.3.1 or later.","what":"CVE-2015-8566 is a high-severity unsafe deserialization vulnerability in n/a, published on 16 Dec 2015. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-8566 and fix it if it is affected.\n\nWhat it is: CVE-2015-8566 is a high-severity unsafe deserialization vulnerability in n/a, published on 16 Dec 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-8566 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- joomla/session (Packagist): affected all versions; fixed in 1.3.1\n- joomla/session (Packagist): affected all versions; fixed in 1.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-8566/ (Markdown: https://insights.sbomify.com/CVE-2015-8566/index.md)","id":"CVE-2015-8566","markdown":"https://insights.sbomify.com/CVE-2015-8566/index.md","name":"CVE-2015-8566","record":{"aliases":["GHSA-wwfh-28hx-w2r2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Joomla Framework Session","requires_auth":"none","summary":"Remote attackers can execute arbitrary code via malicious session values in the Joomla Framework Session package.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"session","vendor":"joomla"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[],"description":"The Session package 1.x before 1.3.1 for Joomla! Framework allows remote attackers to execute arbitrary code via unspecified session values.","ecosystems":["Packagist"],"exploits":{"exploitdb":1,"first_seen":"2015-12-18","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2015-12-18","kind":"exploitdb","ref":"39033","stars":null,"title":"Joomla! 1.5 \u003c 3.4.6 - Object Injection 'x-forwarded-for' Header Remote Code Execution"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Joomla! Framework Remote Code Injection Vulnerability","id":"CVE-2015-8566","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"deserialization","year":"2015"},"n_packages":2,"n_references":2,"next":{"headline":"Denial of service in n/a","id":"CVE-2015-8567"},"packages":[{"ecosystem":"Packagist","fixed":["1.3.1"],"introduced":["0"],"last_affected":[],"package":"joomla/session","purl":null,"source":"GHSA-wwfh-28hx-w2r2"},{"ecosystem":"Packagist","fixed":["1.3.1"],"introduced":["0"],"last_affected":[],"package":"joomla/session","purl":"pkg:composer/joomla/session","source":"GHSA-wwfh-28hx-w2r2"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2015-8565"},"products":["n/a"],"published":"2015-12-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code via malicious session values in the Joomla Framework Session package.","url":"https://insights.sbomify.com/CVE-2015-8566/"}