# CVE-2015-8566: Joomla! Framework Remote Code Injection Vulnerability

> Remote attackers can execute arbitrary code via malicious session values in the Joomla Framework Session package.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Dec 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-wwfh-28hx-w2r2

## What is CVE-2015-8566?

CVE-2015-8566 is a high-severity unsafe deserialization vulnerability in n/a, published on 16 Dec 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Session package 1.x before 1.3.1 for Joomla! Framework allows remote attackers to execute arbitrary code via unspecified session values.

## Which versions are affected by CVE-2015-8566?

2 open source packages ship an affected version, including joomla/session. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `joomla/session` | Packagist | All versions | 1.3.1 |
| `joomla/session` | Packagist | All versions | 1.3.1 |

Products: Joomla Session.

## How do I fix CVE-2015-8566?

Upgrade joomla/session to 1.3.1 or later.

## Is CVE-2015-8566 being exploited?

There is no known exploitation of CVE-2015-8566 in the wild and no public exploit code.

Public exploit code:

- Joomla! 1.5 < 3.4.6 - Object Injection 'x-forwarded-for' Header Remote Code Execution (exploitdb)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-8566 and fix it if it is affected.

What it is: CVE-2015-8566 is a high-severity unsafe deserialization vulnerability in n/a, published on 16 Dec 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-8566 in the wild and no public exploit code.

Affected packages and fixed versions:
- joomla/session (Packagist): affected all versions; fixed in 1.3.1
- joomla/session (Packagist): affected all versions; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-8566/ (Markdown: https://insights.sbomify.com/CVE-2015-8566/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-8566
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-8566
- OSV: https://osv.dev/vulnerability/CVE-2015-8566

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-8566/
Summaries are generated and may contain mistakes; the official description above is the record.
