CVE-2015-8606 Silverstripe CMS XSS Vulnerability
Remote attackers can inject arbitrary web script or HTML into SilverStripe CMS admin forms via specific parameters, potentially compromising user sessions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2015-8606?
CVE-2015-8606 is a medium-severity cross-site scripting vulnerability in Silverstripe Silverstripe, published on 13 Apr 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Multiple cross-site scripting (XSS) vulnerabilities in SilverStripe CMS & Framework before 3.1.16 and 3.2.x before 3.2.1 allow remote attackers to inject arbitrary web script or HTML via the (1) Locale or (2) FailedLoginCount parameter to admin/security/EditForm/field/Members/item/new/ItemEditForm.
Weakness: CWE-79
Which versions are affected by CVE-2015-8606?
4 open source packages ship an affected version, including silverstripe/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
silverstripe/cms Packagist | All versions | 3.1.16 |
silverstripe/cms Packagist | All versions | 3.1.16 |
silverstripe/cms Packagist | From 3.2.0 | 3.2.1 |
silverstripe/cms Packagist | From 3.2.0 | 3.2.1 |
Products include Silverstripe Silverstripe.
How do I fix CVE-2015-8606?
Upgrade silverstripe/cms to a fixed version for your release line: 3.1.16 or 3.2.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2015-8606 being exploited?
There is no known exploitation of CVE-2015-8606 in the wild and no public exploit code.
Other vulnerabilities in Silverstripe Silverstripe
Sources
Also known as GHSA-gvc8-xjfp-6569.