# CVE-2015-8618: Information disclosure in n/a

> A flaw in Go's math/big library mishandles carry propagation, potentially allowing attackers to obtain private RSA keys.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jan 2016
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-f7x9-6qwf-8m25, GO-2021-0160

## What is CVE-2015-8618?

CVE-2015-8618 is a high-severity vulnerability in Golang Go, published on 27 Jan 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Int.Exp Montgomery code in the math/big library in Go 1.5.x before 1.5.3 mishandles carry propagation and produces incorrect output, which makes it easier for attackers to obtain private RSA keys via unspecified vectors.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2015-8618?

1 open source package ship an affected version, including stdlib. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `stdlib` | Go | From 1.5.0-0 | 1.5.3 |

Products: Golang Go, Opensuse Leap.

## How do I fix CVE-2015-8618?

Upgrade stdlib to 1.5.3 or later.

## Is CVE-2015-8618 being exploited?

There is no known exploitation of CVE-2015-8618 in the wild and no public exploit code.

## Other vulnerabilities in Golang Go

- [CVE-2020-0601](https://insights.sbomify.com/CVE-2020-0601/): Microsoft Windows CryptoAPI Spoofing (high 8.1, exploited in the wild)
- [CVE-2026-27143](https://insights.sbomify.com/CVE-2026-27143/): Missing bound checks can lead to memory corruption in safe Go in cmd/compile (critical 9.8)
- [CVE-2024-24790](https://insights.sbomify.com/CVE-2024-24790/): Unexpected behavior from Is methods for IPv4-mapped IPv6 addresses in net/netip (critical 9.8)
- [CVE-2023-39320](https://insights.sbomify.com/CVE-2023-39320/): Arbitrary code execution via go.mod toolchain directive in cmd/go (critical 9.8)
- [CVE-2023-24540](https://insights.sbomify.com/CVE-2023-24540/): Improper handling of JavaScript whitespace in html/template (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-8618 and fix it if it is affected.

What it is: CVE-2015-8618 is a high-severity vulnerability in Golang Go, published on 27 Jan 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-8618 in the wild and no public exploit code.

Affected packages and fixed versions:
- stdlib (Go): affected from 1.5.0-0; fixed in 1.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-8618/ (Markdown: https://insights.sbomify.com/CVE-2015-8618/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-8618
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-8618
- OSV: https://osv.dev/vulnerability/CVE-2015-8618

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-8618/
Summaries are generated and may contain mistakes; the official description above is the record.
