# CVE-2015-8748: Radicale regex metacharacters injection in the user name

> Authenticated users can bypass access control restrictions by injecting regex metacharacters into their username, allowing unauthorized access to resources.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Feb 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-8748, GHSA-6w8c-6jrg-qwj2, MGASA-2016-0057, PYSEC-2016-37

## What is CVE-2015-8748?

CVE-2015-8748 is a medium-severity authentication bypass vulnerability in n/a, published on 3 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Radicale before 1.1 allows remote authenticated users to bypass owner_write and owner_only limitations via regex metacharacters in the user name, as demonstrated by ".*".

Weakness: CWE-264

## Which versions are affected by CVE-2015-8748?

3 open source packages ship an affected version, including radicale and Radicale. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `radicale` | PyPI | All versions | 1.1 |
| `radicale` | PyPI | All versions | 1.1 |
| `Radicale` | PyPI | All versions | 1.1 |

Products: Radicale Radicale.

## How do I fix CVE-2015-8748?

Upgrade radicale to 1.1 or later.

## Is CVE-2015-8748 being exploited?

There is no known exploitation of CVE-2015-8748 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2015-8747](https://insights.sbomify.com/CVE-2015-8747/): Radicale vulnerable to arbitrary file read or write (critical 10.0)
- [CVE-2016-1505](https://insights.sbomify.com/CVE-2016-1505/): Radicale is vulnerable to directory traversal on Windows Filesystem Storage Backend component (critical 10.0)
- [CVE-2017-8342](https://insights.sbomify.com/CVE-2017-8342/): Radicale is vulnerable to timing oracles and simple bruteforce attacks (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-8748 and fix it if it is affected.

What it is: CVE-2015-8748 is a medium-severity authentication bypass vulnerability in n/a, published on 3 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-8748 in the wild and no public exploit code.

Affected packages and fixed versions:
- radicale (PyPI): affected all versions; fixed in 1.1
- radicale (PyPI): affected all versions; fixed in 1.1
- Radicale (PyPI): affected all versions; fixed in 1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-8748/ (Markdown: https://insights.sbomify.com/CVE-2015-8748/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-8748
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-8748
- OSV: https://osv.dev/vulnerability/CVE-2015-8748

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-8748/
Summaries are generated and may contain mistakes; the official description above is the record.
