CVE-2015-8755 Typo3 XSS Vulnerability

Medium 5.4 Published Updated

Authenticated editors can inject arbitrary scripts into TYPO3 backend components, potentially compromising user sessions or data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2015-8755?

CVE-2015-8755 is a medium-severity cross-site scripting vulnerability in Typo3 Typo3, published on 8 Jan 2016. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Multiple cross-site scripting (XSS) vulnerabilities in unspecified backend components in TYPO3 6.2.x before 6.2.16 and 7.x before 7.6.1 allow remote authenticated editors to inject arbitrary web script or HTML via unknown vectors.

Weakness: CWE-79

Which versions are affected by CVE-2015-8755?

4 open source packages ship an affected version, including typo3/cms. It affects 1 product.

PackageAffectedFixed in
typo3/cms PackagistFrom 6.26.2.16
typo3/cms PackagistFrom 6.26.2.16
typo3/cms PackagistFrom 7.07.6.1
typo3/cms PackagistFrom 7.07.6.1

Products include Typo3 Typo3.

How do I fix CVE-2015-8755?

Upgrade typo3/cms to a fixed version for your release line: 6.2.16 or 7.6.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2015-8755 being exploited?

There is no known exploitation of CVE-2015-8755 in the wild and no public exploit code.

All Typo3 Typo3 vulnerabilities

Sources

Also known as GHSA-56f9-5563-m2h7.

Is CVE-2015-8755 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free