CVE-2015-8759 TYPO3 Cross-site Scripting vulnerability

Medium 5.4 Published Updated

Authenticated editors can inject arbitrary web script or HTML via the link field in TYPO3, potentially leading to code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2015-8759?

CVE-2015-8759 is a medium-severity cross-site scripting vulnerability in Typo3 Typo3, published on 8 Jan 2016. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Cross-site scripting (XSS) vulnerability in the typoLink function in TYPO3 6.2.x before 6.2.16 and 7.x before 7.6.1 allows remote authenticated editors to inject arbitrary web script or HTML via a link field.

Weakness: CWE-79

Which versions are affected by CVE-2015-8759?

4 open source packages ship an affected version, including typo3/cms. It affects 1 product.

PackageAffectedFixed in
typo3/cms PackagistFrom 6.2.06.2.16
typo3/cms PackagistFrom 6.2.06.2.16
typo3/cms PackagistFrom 7.0.07.6.1
typo3/cms PackagistFrom 7.0.07.6.1

Products include Typo3 Typo3.

How do I fix CVE-2015-8759?

Upgrade typo3/cms to a fixed version for your release line: 6.2.16 or 7.6.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2015-8759 being exploited?

There is no known exploitation of CVE-2015-8759 in the wild and no public exploit code.

All Typo3 Typo3 vulnerabilities

Sources

Also known as GHSA-j5v7-9xr5-m7gx.

Is CVE-2015-8759 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free