# CVE-2015-8797: Improper Neutralization of Input During Web Page Generation in Apache Solr

> Remote attackers can inject arbitrary web script or HTML into the Apache Solr Admin UI stats page via the entry parameter.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Feb 2016
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-v6gf-x8fp-532v

## What is CVE-2015-8797?

CVE-2015-8797 is a medium-severity cross-site scripting vulnerability in n/a, published on 15 Feb 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in webapp/web/js/scripts/plugins.js in the stats page in the Admin UI in Apache Solr before 5.3.1 allows remote attackers to inject arbitrary web script or HTML via the entry parameter to a plugins/cache URI.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-8797?

2 open source packages ship an affected version, including org.apache.solr:solr-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.solr:solr-core` | Maven | All versions | 5.3.1 |
| `org.apache.solr:solr-core` | Maven | All versions | 5.3.1 |

Products: Apache Solr.

## How do I fix CVE-2015-8797?

Upgrade org.apache.solr:solr-core to 5.3.1 or later.

## Is CVE-2015-8797 being exploited?

There is no known exploitation of CVE-2015-8797 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-17558](https://insights.sbomify.com/CVE-2019-17558/): Apache Solr VelocityResponseWriter Plug-In Remote Code Execution (high 7.5, exploited in the wild)
- [CVE-2019-0193](https://insights.sbomify.com/CVE-2019-0193/): Apache Solr DataImportHandler Code Injection (high 7.2, exploited in the wild)
- [CVE-2024-45216](https://insights.sbomify.com/CVE-2024-45216/): Apache Solr: Authentication bypass possible using a fake URL Path ending (critical 9.8)
- [CVE-2021-44548](https://insights.sbomify.com/CVE-2021-44548/): Apache Solr information disclosure vulnerability through DataImportHandler (critical 9.8)
- [CVE-2021-27905](https://insights.sbomify.com/CVE-2021-27905/): SSRF vulnerability with the Replication handler (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-8797 and fix it if it is affected.

What it is: CVE-2015-8797 is a medium-severity cross-site scripting vulnerability in n/a, published on 15 Feb 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-8797 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.solr:solr-core (Maven): affected all versions; fixed in 5.3.1
- org.apache.solr:solr-core (Maven): affected all versions; fixed in 5.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-8797/ (Markdown: https://insights.sbomify.com/CVE-2015-8797/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-8797
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-8797
- OSV: https://osv.dev/vulnerability/CVE-2015-8797

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-8797/
Summaries are generated and may contain mistakes; the official description above is the record.
