{"answers":{"affected":"2 open source packages ship an affected version, including nokogiri. It affects 3 products.","exploited":"There is no known exploitation of CVE-2015-8806 in the wild and no public exploit code.","fix":"Upgrade nokogiri to 1.6.8 or later.","what":"CVE-2015-8806 is a high-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 13 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-8806 and fix it if it is affected.\n\nWhat it is: CVE-2015-8806 is a high-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 13 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-8806 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nokogiri (RubyGems): affected from 1.6.0; fixed in 1.6.8\n- nokogiri (RubyGems): affected from 1.6.0; fixed in 1.6.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-8806/ (Markdown: https://insights.sbomify.com/CVE-2015-8806/index.md)","id":"CVE-2015-8806","markdown":"https://insights.sbomify.com/CVE-2015-8806/index.md","name":"CVE-2015-8806","record":{"aliases":["DEBIAN-CVE-2015-8806","ECHO-a20a-0b3f-eaef","GHSA-7hp2-xwpj-95jq","UBUNTU-CVE-2015-8806"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"XML parsing library","requires_auth":"none","summary":"Remote attackers can crash applications using libxml2 by sending crafted HTML documents with specific malformed DOCTYPE declarations.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"debian","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"libxml2","vendor":"xmlsoft"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[],"description":"dict.c in libxml2 allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via an unexpected character immediately after the \"\u003c!DOCTYPE html\" substring in a crafted HTML document.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service or RCE from libxml2 and libxslt","id":"CVE-2015-8806","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux","xmlsoft:libxml2"],"type":"denial_of_service","year":"2015"},"n_packages":2,"n_references":7,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2015-8807"},"packages":[{"ecosystem":"RubyGems","fixed":["1.6.8"],"introduced":["1.6.0"],"last_affected":[],"package":"nokogiri","purl":null,"source":"GHSA-7hp2-xwpj-95jq"},{"ecosystem":"RubyGems","fixed":["1.6.8"],"introduced":["1.6.0"],"last_affected":[],"package":"nokogiri","purl":"pkg:gem/nokogiri","source":"GHSA-7hp2-xwpj-95jq"}],"prev":{"headline":"Weak cryptography in n/a","id":"CVE-2015-8805"},"products":["n/a"],"published":"2016-04-13","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can crash applications using libxml2 by sending crafted HTML documents with specific malformed DOCTYPE declarations.","url":"https://insights.sbomify.com/CVE-2015-8806/"}