# CVE-2015-8806: Denial of service or RCE from libxml2 and libxslt

> Remote attackers can crash applications using libxml2 by sending crafted HTML documents with specific malformed DOCTYPE declarations.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Apr 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-8806, ECHO-a20a-0b3f-eaef, GHSA-7hp2-xwpj-95jq, UBUNTU-CVE-2015-8806

## What is CVE-2015-8806?

CVE-2015-8806 is a high-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 13 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

dict.c in libxml2 allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via an unexpected character immediately after the "<!DOCTYPE html" substring in a crafted HTML document.

## Which versions are affected by CVE-2015-8806?

2 open source packages ship an affected version, including nokogiri. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nokogiri` | RubyGems | From 1.6.0 | 1.6.8 |
| `nokogiri` | RubyGems | From 1.6.0 | 1.6.8 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Xmlsoft Libxml2.

## How do I fix CVE-2015-8806?

Upgrade nokogiri to 1.6.8 or later.

## Is CVE-2015-8806 being exploited?

There is no known exploitation of CVE-2015-8806 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-8806 and fix it if it is affected.

What it is: CVE-2015-8806 is a high-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 13 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-8806 in the wild and no public exploit code.

Affected packages and fixed versions:
- nokogiri (RubyGems): affected from 1.6.0; fixed in 1.6.8
- nokogiri (RubyGems): affected from 1.6.0; fixed in 1.6.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-8806/ (Markdown: https://insights.sbomify.com/CVE-2015-8806/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-8806
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-8806
- OSV: https://osv.dev/vulnerability/CVE-2015-8806

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-8806/
Summaries are generated and may contain mistakes; the official description above is the record.
