CVE-2015-8843 Memory corruption in n/a

High 7.4 Published Updated

Local attackers can gain privileges via memory corruption in the Foxit Cloud Update Service when updates are available.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2015-8843?

CVE-2015-8843 is a high-severity memory corruption vulnerability in Foxitsoftware Foxit Reader, published on 13 Apr 2016. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

The Foxit Cloud Update Service (FoxitCloudUpdateService) in Foxit Reader 6.1 through 6.2.x and 7.x before 7.2.2, when an update to the Cloud plugin is available, allows local users to gain privileges by writing crafted data to a shared memory region, which triggers memory corruption.

Weakness: CWE-119

Which versions are affected by CVE-2015-8843?

It affects 1 product.

Products include Foxitsoftware Foxit Reader.

How do I fix CVE-2015-8843?

No fix has been published for CVE-2015-8843 yet. Limit exposure of the affected software until one is available.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2015-8843 being exploited?

There is no known exploitation of CVE-2015-8843 in the wild and no public exploit code.

All Foxitsoftware Foxit Reader vulnerabilities

Sources

Also known as GHSA-rw82-83m8-mfj2.

Is CVE-2015-8843 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free