# CVE-2015-8843: Memory corruption in n/a

> Local attackers can gain privileges via memory corruption in the Foxit Cloud Update Service when updates are available.

- **Severity:** High 7.4 (`CVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Apr 2016
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-rw82-83m8-mfj2

## What is CVE-2015-8843?

CVE-2015-8843 is a high-severity memory corruption vulnerability in Foxitsoftware Foxit Reader, published on 13 Apr 2016. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The Foxit Cloud Update Service (FoxitCloudUpdateService) in Foxit Reader 6.1 through 6.2.x and 7.x before 7.2.2, when an update to the Cloud plugin is available, allows local users to gain privileges by writing crafted data to a shared memory region, which triggers memory corruption.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2015-8843?

It affects 1 product.


Products: Foxitsoftware Foxit Reader.

## How do I fix CVE-2015-8843?

No fix has been published for CVE-2015-8843 yet. Limit exposure of the affected software until one is available.

## Is CVE-2015-8843 being exploited?

There is no known exploitation of CVE-2015-8843 in the wild and no public exploit code.

## Other vulnerabilities in Foxitsoftware Foxit Reader

- [CVE-2021-33793](https://insights.sbomify.com/CVE-2021-33793/): Memory corruption in n/a (critical 9.8)
- [CVE-2021-38568](https://insights.sbomify.com/CVE-2021-38568/): Memory corruption in n/a (critical 9.8)
- [CVE-2021-38572](https://insights.sbomify.com/CVE-2021-38572/): Path traversal in n/a (critical 9.8)
- [CVE-2021-38573](https://insights.sbomify.com/CVE-2021-38573/): Path traversal in n/a (critical 9.8)
- [CVE-2021-38574](https://insights.sbomify.com/CVE-2021-38574/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-8843 and fix it if it is affected.

What it is: CVE-2015-8843 is a high-severity memory corruption vulnerability in Foxitsoftware Foxit Reader, published on 13 Apr 2016. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-8843 in the wild and no public exploit code.

Affected product: Foxitsoftware Foxit Reader. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-8843/ (Markdown: https://insights.sbomify.com/CVE-2015-8843/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-8843
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-8843
- OSV: https://osv.dev/vulnerability/CVE-2015-8843

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-8843/
Summaries are generated and may contain mistakes; the official description above is the record.
