{"answers":{"affected":"2 open source packages ship an affected version, including semver. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-8855 in the wild and no public exploit code.","fix":"Upgrade semver to 4.3.2 or later.","what":"CVE-2015-8855 is a high-severity denial of service vulnerability in Nodejs Node.js, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-8855 and fix it if it is affected.\n\nWhat it is: CVE-2015-8855 is a high-severity denial of service vulnerability in Nodejs Node.js, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-8855 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- semver (npm): affected from 1.0.4; fixed in 4.3.2\n- semver (npm): affected from 1.0.4; fixed in 4.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-8855/ (Markdown: https://insights.sbomify.com/CVE-2015-8855/index.md)","id":"CVE-2015-8855","markdown":"https://insights.sbomify.com/CVE-2015-8855/index.md","name":"CVE-2015-8855","record":{"aliases":["DEBIAN-CVE-2015-8855","GHSA-x6fg-f45m-jf5q","UBUNTU-CVE-2015-8855","USN-4776-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js semver library","requires_auth":"none","summary":"Attackers can cause denial of service via CPU exhaustion using long version strings in the Node.js semver library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"node.js","vendor":"nodejs"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-399","name":null}],"description":"The semver package before 4.3.2 for Node.js allows attackers to cause a denial of service (CPU consumption) via a long version string, aka a \"regular expression denial of service (ReDoS).\"","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial of Service in semver","id":"CVE-2015-8855","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"nodejs:node.js","products":["nodejs:node.js"],"type":"denial_of_service","year":"2015"},"n_packages":2,"n_references":3,"next":{"headline":"Cross-Site Scripting in serve-index","id":"CVE-2015-8856"},"packages":[{"ecosystem":"npm","fixed":["4.3.2"],"introduced":["1.0.4"],"last_affected":[],"package":"semver","purl":null,"source":"GHSA-x6fg-f45m-jf5q"},{"ecosystem":"npm","fixed":["4.3.2"],"introduced":["1.0.4"],"last_affected":[],"package":"semver","purl":"pkg:npm/semver","source":"GHSA-x6fg-f45m-jf5q"}],"prev":{"headline":"Regular Expression Denial of Service in marked","id":"CVE-2015-8854"},"products":["n/a"],"published":"2017-01-23","related":[{"cvss_score":9.8,"headline":"Security feature bypass in Node","id":"CVE-2023-32002","kev_date_added":null,"published":"2023-08-21"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2016-6303","kev_date_added":null,"published":"2016-09-16"},{"cvss_score":9.1,"headline":"Security feature bypass in Node.js","id":"CVE-2017-15896","kev_date_added":null,"published":"2017-12-11"},{"cvss_score":8.8,"headline":"Server-side request forgery in Node.js","id":"CVE-2018-7160","kev_date_added":null,"published":"2018-05-17"},{"cvss_score":8.1,"headline":"Misconfiguration in Node.js","id":"CVE-2018-12120","kev_date_added":null,"published":"2018-11-28"},{"cvss_score":7.9,"headline":"Path traversal in Node","id":"CVE-2024-21891","kev_date_added":null,"published":"2024-02-20"},{"cvss_score":7.9,"headline":"Path traversal in Node","id":"CVE-2024-21896","kev_date_added":null,"published":"2024-02-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can cause denial of service via CPU exhaustion using long version strings in the Node.js semver library.","url":"https://insights.sbomify.com/CVE-2015-8855/"}