# CVE-2015-8855: Regular Expression Denial of Service in semver

> Attackers can cause denial of service via CPU exhaustion using long version strings in the Node.js semver library.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jan 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-8855, GHSA-x6fg-f45m-jf5q, UBUNTU-CVE-2015-8855, USN-4776-1

## What is CVE-2015-8855?

CVE-2015-8855 is a high-severity denial of service vulnerability in Nodejs Node.js, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The semver package before 4.3.2 for Node.js allows attackers to cause a denial of service (CPU consumption) via a long version string, aka a "regular expression denial of service (ReDoS)."

Weakness: CWE-399

## Which versions are affected by CVE-2015-8855?

2 open source packages ship an affected version, including semver. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `semver` | npm | From 1.0.4 | 4.3.2 |
| `semver` | npm | From 1.0.4 | 4.3.2 |

Products: Nodejs Node.js.

## How do I fix CVE-2015-8855?

Upgrade semver to 4.3.2 or later.

## Is CVE-2015-8855 being exploited?

There is no known exploitation of CVE-2015-8855 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Node.js

- [CVE-2023-32002](https://insights.sbomify.com/CVE-2023-32002/): Security feature bypass in Node (critical 9.8)
- [CVE-2016-6303](https://insights.sbomify.com/CVE-2016-6303/): Integer overflow in n/a (critical 9.8)
- [CVE-2017-15896](https://insights.sbomify.com/CVE-2017-15896/): Security feature bypass in Node.js (critical 9.1)
- [CVE-2018-7160](https://insights.sbomify.com/CVE-2018-7160/): Server-side request forgery in Node.js (high 8.8)
- [CVE-2018-12120](https://insights.sbomify.com/CVE-2018-12120/): Misconfiguration in Node.js (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-8855 and fix it if it is affected.

What it is: CVE-2015-8855 is a high-severity denial of service vulnerability in Nodejs Node.js, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-8855 in the wild and no public exploit code.

Affected packages and fixed versions:
- semver (npm): affected from 1.0.4; fixed in 4.3.2
- semver (npm): affected from 1.0.4; fixed in 4.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-8855/ (Markdown: https://insights.sbomify.com/CVE-2015-8855/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-8855
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-8855
- OSV: https://osv.dev/vulnerability/CVE-2015-8855

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-8855/
Summaries are generated and may contain mistakes; the official description above is the record.
