{"answers":{"affected":"2 open source packages ship an affected version, including serve-index. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-8856 in the wild and no public exploit code.","fix":"Upgrade serve-index to 1.6.3 or later.","what":"CVE-2015-8856 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-8856 and fix it if it is affected.\n\nWhat it is: CVE-2015-8856 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-8856 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- serve-index (npm): affected all versions; fixed in 1.6.3\n- serve-index (npm): affected all versions; fixed in 1.6.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-8856/ (Markdown: https://insights.sbomify.com/CVE-2015-8856/index.md)","id":"CVE-2015-8856","markdown":"https://insights.sbomify.com/CVE-2015-8856/index.md","name":"CVE-2015-8856","record":{"aliases":["DEBIAN-CVE-2015-8856","GHSA-v633-x5vv-hqwc","UBUNTU-CVE-2015-8856"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js serve-index package","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via crafted file or directory names in the serve-index package.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"serve-index","vendor":"openjsf"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in the serve-index package before 1.6.3 for Node.js allows remote attackers to inject arbitrary web script or HTML via a crafted file or directory name.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-Site Scripting in serve-index","id":"CVE-2015-8856","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2015"},"n_packages":2,"n_references":3,"next":{"headline":"Incorrect Handling of Non-Boolean Comparisons During Minification in uglify-js","id":"CVE-2015-8857"},"packages":[{"ecosystem":"npm","fixed":["1.6.3"],"introduced":["0"],"last_affected":[],"package":"serve-index","purl":null,"source":"GHSA-v633-x5vv-hqwc"},{"ecosystem":"npm","fixed":["1.6.3"],"introduced":["0"],"last_affected":[],"package":"serve-index","purl":"pkg:npm/serve-index","source":"GHSA-v633-x5vv-hqwc"}],"prev":{"headline":"Regular Expression Denial of Service in semver","id":"CVE-2015-8855"},"products":["n/a"],"published":"2017-01-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via crafted file or directory names in the serve-index package.","url":"https://insights.sbomify.com/CVE-2015-8856/"}