{"answers":{"affected":"4 open source packages ship an affected version, including uglifier and uglify-js. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-8857 in the wild and no public exploit code.","fix":"Upgrade uglifier to 2.7.2 or later.","what":"CVE-2015-8857 is a critical vulnerability in n/a, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-8857 and fix it if it is affected.\n\nWhat it is: CVE-2015-8857 is a critical vulnerability in n/a, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-8857 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- uglifier (RubyGems): affected all versions; fixed in 2.7.2\n- uglifier (RubyGems): affected all versions; fixed in 2.7.2\n- uglify-js (npm): affected all versions; fixed in 2.4.24\n- uglify-js (npm): affected all versions; fixed in 2.4.24\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-8857/ (Markdown: https://insights.sbomify.com/CVE-2015-8857/index.md)","id":"CVE-2015-8857","markdown":"https://insights.sbomify.com/CVE-2015-8857/index.md","name":"CVE-2015-8857","record":{"aliases":["DEBIAN-CVE-2015-8857","GHSA-34r7-q49f-h37c","UBUNTU-CVE-2015-8857"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript minifier library","requires_auth":"none","summary":"Attackers can bypass security mechanisms by exploiting improper boolean expression rewriting in the uglify-js JavaScript minifier library.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"uglifyjs","vendor":"uglifyjs_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-254","name":null}],"description":"The uglify-js package before 2.4.24 for Node.js does not properly account for non-boolean values when rewriting boolean expressions, which might allow attackers to bypass security mechanisms or possibly have unspecified other impact by leveraging improperly rewritten Javascript.","ecosystems":["RubyGems","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Incorrect Handling of Non-Boolean Comparisons During Minification in uglify-js","id":"CVE-2015-8857","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"security_feature_bypass","year":"2015"},"n_packages":4,"n_references":3,"next":{"headline":"Regular Expression Denial of Service in uglify-js","id":"CVE-2015-8858"},"packages":[{"ecosystem":"RubyGems","fixed":["2.7.2"],"introduced":["0"],"last_affected":[],"package":"uglifier","purl":null,"source":"GHSA-34r7-q49f-h37c"},{"ecosystem":"RubyGems","fixed":["2.7.2"],"introduced":["0"],"last_affected":[],"package":"uglifier","purl":"pkg:gem/uglifier","source":"GHSA-34r7-q49f-h37c"},{"ecosystem":"npm","fixed":["2.4.24"],"introduced":["0"],"last_affected":[],"package":"uglify-js","purl":null,"source":"GHSA-34r7-q49f-h37c"},{"ecosystem":"npm","fixed":["2.4.24"],"introduced":["0"],"last_affected":[],"package":"uglify-js","purl":"pkg:npm/uglify-js","source":"GHSA-34r7-q49f-h37c"}],"prev":{"headline":"Cross-Site Scripting in serve-index","id":"CVE-2015-8856"},"products":["n/a"],"published":"2017-01-23","related":[{"cvss_score":9.8,"headline":"Other in n/a","id":"CVE-2022-37598","kev_date_added":null,"published":"2022-10-20"},{"cvss_score":7.5,"headline":"Regular Expression Denial of Service in uglify-js","id":"CVE-2015-8858","kev_date_added":null,"published":"2017-01-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can bypass security mechanisms by exploiting improper boolean expression rewriting in the uglify-js JavaScript minifier library.","url":"https://insights.sbomify.com/CVE-2015-8857/"}