# CVE-2015-8857: Incorrect Handling of Non-Boolean Comparisons During Minification in uglify-js

> Attackers can bypass security mechanisms by exploiting improper boolean expression rewriting in the uglify-js JavaScript minifier library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jan 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-8857, GHSA-34r7-q49f-h37c, UBUNTU-CVE-2015-8857

## What is CVE-2015-8857?

CVE-2015-8857 is a critical vulnerability in n/a, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The uglify-js package before 2.4.24 for Node.js does not properly account for non-boolean values when rewriting boolean expressions, which might allow attackers to bypass security mechanisms or possibly have unspecified other impact by leveraging improperly rewritten Javascript.

Weakness: CWE-254

## Which versions are affected by CVE-2015-8857?

4 open source packages ship an affected version, including uglifier and uglify-js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `uglifier` | RubyGems | All versions | 2.7.2 |
| `uglifier` | RubyGems | All versions | 2.7.2 |
| `uglify-js` | npm | All versions | 2.4.24 |
| `uglify-js` | npm | All versions | 2.4.24 |

Products: Uglifyjs Project Uglifyjs.

## How do I fix CVE-2015-8857?

Upgrade uglifier to 2.7.2 or later.

## Is CVE-2015-8857 being exploited?

There is no known exploitation of CVE-2015-8857 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-37598](https://insights.sbomify.com/CVE-2022-37598/): Other in n/a (critical 9.8)
- [CVE-2015-8858](https://insights.sbomify.com/CVE-2015-8858/): Regular Expression Denial of Service in uglify-js (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-8857 and fix it if it is affected.

What it is: CVE-2015-8857 is a critical vulnerability in n/a, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-8857 in the wild and no public exploit code.

Affected packages and fixed versions:
- uglifier (RubyGems): affected all versions; fixed in 2.7.2
- uglifier (RubyGems): affected all versions; fixed in 2.7.2
- uglify-js (npm): affected all versions; fixed in 2.4.24
- uglify-js (npm): affected all versions; fixed in 2.4.24

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-8857/ (Markdown: https://insights.sbomify.com/CVE-2015-8857/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-8857
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-8857
- OSV: https://osv.dev/vulnerability/CVE-2015-8857

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-8857/
Summaries are generated and may contain mistakes; the official description above is the record.
