{"answers":{"affected":"2 open source packages ship an affected version, including uglify-js. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-8858 in the wild and no public exploit code.","fix":"Upgrade uglify-js to 2.6.0 or later.","what":"CVE-2015-8858 is a high-severity denial of service vulnerability in n/a, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-8858 and fix it if it is affected.\n\nWhat it is: CVE-2015-8858 is a high-severity denial of service vulnerability in n/a, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-8858 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- uglify-js (npm): affected all versions; fixed in 2.6.0\n- uglify-js (npm): affected all versions; fixed in 2.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-8858/ (Markdown: https://insights.sbomify.com/CVE-2015-8858/index.md)","id":"CVE-2015-8858","markdown":"https://insights.sbomify.com/CVE-2015-8858/index.md","name":"CVE-2015-8858","record":{"aliases":["DEBIAN-CVE-2015-8858","GHSA-c9f4-xj24-8jqx","UBUNTU-CVE-2015-8858"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript minifier library","requires_auth":"none","summary":"Attackers can cause denial of service via CPU exhaustion in the uglify-js library using crafted input, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"uglifyjs","vendor":"uglifyjs_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-399","name":null}],"description":"The uglify-js package before 2.6.0 for Node.js allows attackers to cause a denial of service (CPU consumption) via crafted input in a parse call, aka a \"regular expression denial of service (ReDoS).\"","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial of Service in uglify-js","id":"CVE-2015-8858","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2015"},"n_packages":2,"n_references":3,"next":{"headline":"Root Path Disclosure in send","id":"CVE-2015-8859"},"packages":[{"ecosystem":"npm","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"uglify-js","purl":null,"source":"GHSA-c9f4-xj24-8jqx"},{"ecosystem":"npm","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"uglify-js","purl":"pkg:npm/uglify-js","source":"GHSA-c9f4-xj24-8jqx"}],"prev":{"headline":"Incorrect Handling of Non-Boolean Comparisons During Minification in uglify-js","id":"CVE-2015-8857"},"products":["n/a"],"published":"2017-01-23","related":[{"cvss_score":9.8,"headline":"Other in n/a","id":"CVE-2022-37598","kev_date_added":null,"published":"2022-10-20"},{"cvss_score":9.8,"headline":"Incorrect Handling of Non-Boolean Comparisons During Minification in uglify-js","id":"CVE-2015-8857","kev_date_added":null,"published":"2017-01-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can cause denial of service via CPU exhaustion in the uglify-js library using crafted input, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2015-8858/"}