# CVE-2015-8860: Symlink Arbitrary File Overwrite in tar

> Remote attackers can write to arbitrary files via symlink attacks in archives using the Node.js tar library.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jan 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-8860, GHSA-gfjr-3jmm-4g9v, UBUNTU-CVE-2015-8860, USN-4777-1

## What is CVE-2015-8860?

CVE-2015-8860 is a high-severity path traversal vulnerability in Nodejs Node.js, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The tar package before 2.0.0 for Node.js allows remote attackers to write to arbitrary files via a symlink attack in an archive.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2015-8860?

2 open source packages ship an affected version, including tar. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tar` | npm | All versions | 2.0.0 |
| `tar` | npm | All versions | 2.0.0 |

Products: Nodejs Node.js.

## How do I fix CVE-2015-8860?

Upgrade tar to 2.0.0 or later.

## Is CVE-2015-8860 being exploited?

There is no known exploitation of CVE-2015-8860 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Node.js

- [CVE-2023-32002](https://insights.sbomify.com/CVE-2023-32002/): Security feature bypass in Node (critical 9.8)
- [CVE-2016-6303](https://insights.sbomify.com/CVE-2016-6303/): Integer overflow in n/a (critical 9.8)
- [CVE-2017-15896](https://insights.sbomify.com/CVE-2017-15896/): Security feature bypass in Node.js (critical 9.1)
- [CVE-2018-7160](https://insights.sbomify.com/CVE-2018-7160/): Server-side request forgery in Node.js (high 8.8)
- [CVE-2018-12120](https://insights.sbomify.com/CVE-2018-12120/): Misconfiguration in Node.js (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-8860 and fix it if it is affected.

What it is: CVE-2015-8860 is a high-severity path traversal vulnerability in Nodejs Node.js, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-8860 in the wild and no public exploit code.

Affected packages and fixed versions:
- tar (npm): affected all versions; fixed in 2.0.0
- tar (npm): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-8860/ (Markdown: https://insights.sbomify.com/CVE-2015-8860/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-8860
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-8860
- OSV: https://osv.dev/vulnerability/CVE-2015-8860

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-8860/
Summaries are generated and may contain mistakes; the official description above is the record.
