# CVE-2015-8862: Cross-Site Scripting in mustache

> Remote attackers can execute arbitrary scripts via unquoted attributes in mustache templates, affecting Node.js applications using this library.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jan 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-8862, GHSA-w3w8-37jv-2c58

## What is CVE-2015-8862?

CVE-2015-8862 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

mustache package before 2.2.1 for Node.js allows remote attackers to conduct cross-site scripting (XSS) attacks by leveraging a template with an attribute that is not quoted.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-8862?

2 open source packages ship an affected version, including mustache. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mustache` | npm | All versions | 2.2.1 |
| `mustache` | npm | All versions | 2.2.1 |

Products: Mustache.js Project Mustache.js.

## How do I fix CVE-2015-8862?

Upgrade mustache to 2.2.1 or later.

## Is CVE-2015-8862 being exploited?

There is no known exploitation of CVE-2015-8862 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-8862 and fix it if it is affected.

What it is: CVE-2015-8862 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-8862 in the wild and no public exploit code.

Affected packages and fixed versions:
- mustache (npm): affected all versions; fixed in 2.2.1
- mustache (npm): affected all versions; fixed in 2.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-8862/ (Markdown: https://insights.sbomify.com/CVE-2015-8862/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-8862
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-8862
- OSV: https://osv.dev/vulnerability/CVE-2015-8862

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-8862/
Summaries are generated and may contain mistakes; the official description above is the record.
