{"answers":{"affected":"2 open source packages ship an affected version, including git-fastclone. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-8968 in the wild and no public exploit code.","fix":"Upgrade git-fastclone to 1.0.1 or later.","what":"CVE-2015-8968 is a high-severity command injection vulnerability in git-fastclone ruby gem All versions before 1.0.1, published on 3 Nov 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-8968 and fix it if it is affected.\n\nWhat it is: CVE-2015-8968 is a high-severity command injection vulnerability in git-fastclone ruby gem All versions before 1.0.1, published on 3 Nov 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-8968 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- git-fastclone (RubyGems): affected all versions; fixed in 1.0.1\n- git-fastclone (RubyGems): affected all versions; fixed in 1.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-8968/ (Markdown: https://insights.sbomify.com/CVE-2015-8968/index.md)","id":"CVE-2015-8968","markdown":"https://insights.sbomify.com/CVE-2015-8968/index.md","name":"CVE-2015-8968","record":{"aliases":["GHSA-8gg6-3r63-25m8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby gem","requires_auth":"none","summary":"Attackers can execute arbitrary shell commands via malicious .gitmodules files when users perform recursive clones or submodule updates.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"git-fastclone","vendor":"squareup"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"git-fastclone before 1.0.1 permits arbitrary shell command execution from .gitmodules. If an attacker can instruct a user to run a recursive clone from a repository they control, they can get a client to run an arbitrary shell command. Alternately, if an attacker can MITM an unencrypted git clone, they could exploit this. The ext command will be run if the repository is recursively cloned or if submodules are updated. This attack works when cloning both local and remote repositories.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"git-fastclone permits arbitrary shell command execution from .gitmodules","id":"CVE-2015-8968","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"command_injection","year":"2015"},"n_packages":2,"n_references":3,"next":{"headline":"Git-fastclone passes user modifiable strings directly to a shell command","id":"CVE-2015-8969"},"packages":[{"ecosystem":"RubyGems","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"git-fastclone","purl":null,"source":"GHSA-8gg6-3r63-25m8"},{"ecosystem":"RubyGems","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"git-fastclone","purl":"pkg:gem/git-fastclone","source":"GHSA-8gg6-3r63-25m8"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2015-8967"},"products":["git-fastclone ruby gem All versions before 1.0.1"],"published":"2016-11-03","related":[{"cvss_score":9.8,"headline":"Git-fastclone passes user modifiable strings directly to a shell command","id":"CVE-2015-8969","kev_date_added":null,"published":"2016-11-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can execute arbitrary shell commands via malicious .gitmodules files when users perform recursive clones or submodule updates.","url":"https://insights.sbomify.com/CVE-2015-8968/"}