# CVE-2015-8969: Git-fastclone passes user modifiable strings directly to a shell command


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 3 Nov 2016
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-mf6w-45cf-qhmp

## What is CVE-2015-8969?

CVE-2015-8969 is a critical vulnerability in git-fastclone ruby gem All versions before 1.0.5, published on 3 Nov 2016. 

### Official description

git-fastclone before 1.0.5 passes user modifiable strings directly to a shell command. An attacker can execute malicious commands by modifying the strings that are passed as arguments to "cd " and "git clone " commands in the library.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2015-8969?

2 open source packages ship an affected version, including git-fastclone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `git-fastclone` | RubyGems | All versions | 1.0.5 |
| `git-fastclone` | RubyGems | All versions | 1.0.5 |

Products: Squareup Git-Fastclone.

## How do I fix CVE-2015-8969?

Upgrade git-fastclone to 1.0.5 or later.

## Is CVE-2015-8969 being exploited?

There is no known exploitation of CVE-2015-8969 in the wild and no public exploit code.

## Other vulnerabilities in git-fastclone ruby gem All versions before 1.0.5

- [CVE-2015-8968](https://insights.sbomify.com/CVE-2015-8968/): git-fastclone permits arbitrary shell command execution from .gitmodules (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-8969 and fix it if it is affected.

What it is: CVE-2015-8969 is a critical vulnerability in git-fastclone ruby gem All versions before 1.0.5, published on 3 Nov 2016. 
Exploitation: There is no known exploitation of CVE-2015-8969 in the wild and no public exploit code.

Affected packages and fixed versions:
- git-fastclone (RubyGems): affected all versions; fixed in 1.0.5
- git-fastclone (RubyGems): affected all versions; fixed in 1.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-8969/ (Markdown: https://insights.sbomify.com/CVE-2015-8969/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-8969
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-8969
- OSV: https://osv.dev/vulnerability/CVE-2015-8969

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-8969/
Summaries are generated and may contain mistakes; the official description above is the record.
