{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-8978 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2015-8978 is a high-severity denial of service vulnerability in n/a, published on 22 Nov 2016. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-8978 and fix it if it is affected.\n\nWhat it is: CVE-2015-8978 is a high-severity denial of service vulnerability in n/a, published on 22 Nov 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-8978 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-8978/ (Markdown: https://insights.sbomify.com/CVE-2015-8978/index.md)","id":"CVE-2015-8978","markdown":"https://insights.sbomify.com/CVE-2015-8978/index.md","name":"CVE-2015-8978","record":{"aliases":["DEBIAN-CVE-2015-8978","DLA-723-1","GHSA-9xh5-ghq7-m3c5","MGASA-2017-0252","SUSE-SU-2016:3052-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Perl SOAP library","requires_auth":"none","summary":"An attacker can cause a denial of service in the Perl SOAP::Lite library by sending a crafted XML document that triggers excessive memory consumption via entity expansion.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"\\","vendor":"soap\\"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-399","name":null}],"description":"In Soap Lite (aka the SOAP::Lite extension for Perl) 1.14 and earlier, an example attack consists of defining 10 or more XML entities, each defined as consisting of 10 of the previous entity, with the document consisting of a single instance of the largest entity, which expands to one billion copies of the first entity. The amount of computer memory used for handling an external SOAP call would likely exceed that available to the process parsing the XML.","ecosystems":["SUSE:Linux Enterprise Software Development Kit 11 SP4"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2015-8978","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2015"},"n_packages":1,"n_references":2,"next":{"headline":"Memory corruption in n/a","id":"CVE-2015-8979"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 11 SP4","fixed":["0.710.08-3.1"],"introduced":["0"],"last_affected":[],"package":"perl-SOAP-Lite","purl":"pkg:rpm/suse/perl-SOAP-Lite\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2011%20SP4","source":"SUSE-SU-2016:3052-1"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2015-8977"},"products":["n/a"],"published":"2016-11-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"An attacker can cause a denial of service in the Perl SOAP::Lite library by sending a crafted XML document that triggers excessive memory consumption via entity expansion.","url":"https://insights.sbomify.com/CVE-2015-8978/"}