{"answers":{"affected":"2 open source packages ship an affected version, including mail. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-9097 in the wild and no public exploit code.","fix":"Upgrade mail to 2.5.5 or later.","what":"CVE-2015-9097 is a medium-severity command injection vulnerability in n/a, published on 12 Jun 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-9097 and fix it if it is affected.\n\nWhat it is: CVE-2015-9097 is a medium-severity command injection vulnerability in n/a, published on 12 Jun 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-9097 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mail (RubyGems): affected all versions; fixed in 2.5.5\n- mail (RubyGems): affected all versions; fixed in 2.5.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-9097/ (Markdown: https://insights.sbomify.com/CVE-2015-9097/index.md)","id":"CVE-2015-9097","markdown":"https://insights.sbomify.com/CVE-2015-9097/index.md","name":"CVE-2015-9097","record":{"aliases":["DEBIAN-CVE-2015-9097","DLA-489-1","GHSA-q86f-fmqf-qrf6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby mail library","requires_auth":"none","summary":"Attackers can execute arbitrary SMTP commands via CRLF injection in the Ruby mail gem, potentially leading to code execution.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mail","vendor":"mail_project"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-93","name":"Improper Neutralization of CRLF Sequences"}],"description":"The mail gem before 2.5.5 for Ruby (aka A Really Ruby Mail Library) is vulnerable to SMTP command injection via CRLF sequences in a RCPT TO or MAIL FROM command, as demonstrated by CRLF sequences immediately before and after a DATA substring.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Mail Gem CRLF Injection vulnerability","id":"CVE-2015-9097","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"command_injection","year":"2015"},"n_packages":2,"n_references":7,"next":{"headline":"SQL injection in n/a","id":"CVE-2015-9098"},"packages":[{"ecosystem":"RubyGems","fixed":["2.5.5"],"introduced":["0"],"last_affected":[],"package":"mail","purl":null,"source":"GHSA-q86f-fmqf-qrf6"},{"ecosystem":"RubyGems","fixed":["2.5.5"],"introduced":["0"],"last_affected":[],"package":"mail","purl":"pkg:gem/mail","source":"GHSA-q86f-fmqf-qrf6"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2015-9096"},"products":["n/a"],"published":"2017-06-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers can execute arbitrary SMTP commands via CRLF injection in the Ruby mail gem, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2015-9097/"}