{"answers":{"affected":"2 open source packages ship an affected version, including hapi. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-9236 in the wild and no public exploit code.","fix":"Upgrade hapi to 11.0.0 or later.","what":"CVE-2015-9236 is a medium-severity vulnerability in HackerOne hapi node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-9236 and fix it if it is affected.\n\nWhat it is: CVE-2015-9236 is a medium-severity vulnerability in HackerOne hapi node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-9236 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- hapi (npm): affected all versions; fixed in 11.0.0\n- hapi (npm): affected all versions; fixed in 11.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-9236/ (Markdown: https://insights.sbomify.com/CVE-2015-9236/index.md)","id":"CVE-2015-9236","markdown":"https://insights.sbomify.com/CVE-2015-9236/index.md","name":"CVE-2015-9236","record":{"aliases":["GHSA-vwrf-r5r4-7775"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Hapi web framework","requires_auth":"none","summary":"Incorrect CORS implementation in Hapi allows bypassing route-specific restrictions, enabling unauthorized cross-origin requests when CORS is disabled on specific routes.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"hapi","vendor":"hapijs"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"},{"id":"CWE-284","name":"Improper Access Control"}],"description":"Hapi versions less than 11.0.0 implement CORS incorrectly and allowed for configurations that at best returned inconsistent headers and at worst allowed cross-origin activities that were expected to be forbidden. If the connection has CORS enabled but one route has it off, and the route is not GET, the OPTIONS prefetch request will return the default CORS headers and then the actual request will go through and return no CORS headers. This defeats the purpose of turning CORS on the route.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Incorrect handling of CORS preflight request headers in hapi","id":"CVE-2015-9236","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2015"},"n_packages":2,"n_references":3,"next":{"headline":"Insecure Comparison in secure-compare","id":"CVE-2015-9238"},"packages":[{"ecosystem":"npm","fixed":["11.0.0"],"introduced":["0"],"last_affected":[],"package":"hapi","purl":null,"source":"GHSA-vwrf-r5r4-7775"},{"ecosystem":"npm","fixed":["11.0.0"],"introduced":["0"],"last_affected":[],"package":"hapi","purl":"pkg:npm/hapi","source":"GHSA-vwrf-r5r4-7775"}],"prev":{"headline":"Verification Bypass in jsonwebtoken","id":"CVE-2015-9235"},"products":["hapi node module"],"published":"2018-05-31","related":[{"cvss_score":7.5,"headline":"Denial of Service via malformed accept-encoding header in hapi","id":"CVE-2017-16013","kev_date_added":null,"published":"2018-06-04"},{"cvss_score":7.5,"headline":"Denial of Service in hapi","id":"CVE-2015-9241","kev_date_added":null,"published":"2018-05-29"},{"cvss_score":5.9,"headline":"Unsafe Merging of CORS Configuration Conflict in hapi","id":"CVE-2015-9243","kev_date_added":null,"published":"2018-05-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["HackerOne"]},"summary":"Incorrect CORS implementation in Hapi allows bypassing route-specific restrictions, enabling unauthorized cross-origin requests when CORS is disabled on specific routes.","url":"https://insights.sbomify.com/CVE-2015-9236/"}