# CVE-2015-9236: Incorrect handling of CORS preflight request headers in hapi

> Incorrect CORS implementation in Hapi allows bypassing route-specific restrictions, enabling unauthorized cross-origin requests when CORS is disabled on specific routes.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-vwrf-r5r4-7775

## What is CVE-2015-9236?

CVE-2015-9236 is a medium-severity vulnerability in HackerOne hapi node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Hapi versions less than 11.0.0 implement CORS incorrectly and allowed for configurations that at best returned inconsistent headers and at worst allowed cross-origin activities that were expected to be forbidden. If the connection has CORS enabled but one route has it off, and the route is not GET, the OPTIONS prefetch request will return the default CORS headers and then the actual request will go through and return no CORS headers. This defeats the purpose of turning CORS on the route.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2015-9236?

2 open source packages ship an affected version, including hapi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hapi` | npm | All versions | 11.0.0 |
| `hapi` | npm | All versions | 11.0.0 |

Products: Hapijs Hapi.

## How do I fix CVE-2015-9236?

Upgrade hapi to 11.0.0 or later.

## Is CVE-2015-9236 being exploited?

There is no known exploitation of CVE-2015-9236 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne hapi node module

- [CVE-2017-16013](https://insights.sbomify.com/CVE-2017-16013/): Denial of Service via malformed accept-encoding header in hapi (high 7.5)
- [CVE-2015-9241](https://insights.sbomify.com/CVE-2015-9241/): Denial of Service in hapi (high 7.5)
- [CVE-2015-9243](https://insights.sbomify.com/CVE-2015-9243/): Unsafe Merging of CORS Configuration Conflict in hapi (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-9236 and fix it if it is affected.

What it is: CVE-2015-9236 is a medium-severity vulnerability in HackerOne hapi node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-9236 in the wild and no public exploit code.

Affected packages and fixed versions:
- hapi (npm): affected all versions; fixed in 11.0.0
- hapi (npm): affected all versions; fixed in 11.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-9236/ (Markdown: https://insights.sbomify.com/CVE-2015-9236/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-9236
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-9236
- OSV: https://osv.dev/vulnerability/CVE-2015-9236

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-9236/
Summaries are generated and may contain mistakes; the official description above is the record.
