{"answers":{"affected":"2 open source packages ship an affected version, including secure-compare. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-9238 in the wild and no public exploit code.","fix":"Upgrade secure-compare to 3.0.1 or later.","what":"CVE-2015-9238 is a medium-severity vulnerability in HackerOne secure-compare node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-9238 and fix it if it is affected.\n\nWhat it is: CVE-2015-9238 is a medium-severity vulnerability in HackerOne secure-compare node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-9238 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- secure-compare (npm): affected all versions; fixed in 3.0.1\n- secure-compare (npm): affected all versions; fixed in 3.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-9238/ (Markdown: https://insights.sbomify.com/CVE-2015-9238/index.md)","id":"CVE-2015-9238","markdown":"https://insights.sbomify.com/CVE-2015-9238/index.md","name":"CVE-2015-9238","record":{"aliases":["GHSA-h9x2-5rm7-x4gm"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js secure-compare library","requires_auth":"none","summary":"The secure-compare library fails to validate string equality correctly, allowing attackers to bypass security checks that rely on this comparison.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"secure-compare","vendor":"secure-compare_project"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-134","name":"Use of Externally-Controlled Format String"},{"id":"CWE-697","name":"Incorrect Comparison"}],"description":"secure-compare 3.0.0 and below do not actually compare two strings properly. compare was actually comparing the first argument with itself, meaning the check passed for any two strings of the same length.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2024-11-24","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-11-24T01:49:24Z","kind":"github_poc","ref":"https://github.com/m0d0ri205/wargame-turkey_in_2","stars":0,"title":"CVE-2015-9238, Unicode bypass"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Insecure Comparison in secure-compare","id":"CVE-2015-9238","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2015"},"n_packages":2,"n_references":2,"next":{"headline":"Regular Expression Denial of Service in ansi2html","id":"CVE-2015-9239"},"packages":[{"ecosystem":"npm","fixed":["3.0.1"],"introduced":["0"],"last_affected":[],"package":"secure-compare","purl":null,"source":"GHSA-h9x2-5rm7-x4gm"},{"ecosystem":"npm","fixed":["3.0.1"],"introduced":["0"],"last_affected":[],"package":"secure-compare","purl":"pkg:npm/secure-compare","source":"GHSA-h9x2-5rm7-x4gm"}],"prev":{"headline":"Incorrect handling of CORS preflight request headers in hapi","id":"CVE-2015-9236"},"products":["secure-compare node module"],"published":"2018-05-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["HackerOne"]},"summary":"The secure-compare library fails to validate string equality correctly, allowing attackers to bypass security checks that rely on this comparison.","url":"https://insights.sbomify.com/CVE-2015-9238/"}