# CVE-2015-9238: Insecure Comparison in secure-compare

> The secure-compare library fails to validate string equality correctly, allowing attackers to bypass security checks that rely on this comparison.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-h9x2-5rm7-x4gm

## What is CVE-2015-9238?

CVE-2015-9238 is a medium-severity vulnerability in HackerOne secure-compare node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

secure-compare 3.0.0 and below do not actually compare two strings properly. compare was actually comparing the first argument with itself, meaning the check passed for any two strings of the same length.

Weakness: CWE-134 (Use of Externally-Controlled Format String), CWE-697 (Incorrect Comparison)

## Which versions are affected by CVE-2015-9238?

2 open source packages ship an affected version, including secure-compare. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `secure-compare` | npm | All versions | 3.0.1 |
| `secure-compare` | npm | All versions | 3.0.1 |

Products: Secure-Compare Project Secure-Compare.

## How do I fix CVE-2015-9238?

Upgrade secure-compare to 3.0.1 or later.

## Is CVE-2015-9238 being exploited?

There is no known exploitation of CVE-2015-9238 in the wild and no public exploit code.

Public exploit code:

- CVE-2015-9238, Unicode bypass (github_poc): https://github.com/m0d0ri205/wargame-turkey_in_2

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-9238 and fix it if it is affected.

What it is: CVE-2015-9238 is a medium-severity vulnerability in HackerOne secure-compare node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-9238 in the wild and no public exploit code.

Affected packages and fixed versions:
- secure-compare (npm): affected all versions; fixed in 3.0.1
- secure-compare (npm): affected all versions; fixed in 3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-9238/ (Markdown: https://insights.sbomify.com/CVE-2015-9238/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-9238
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-9238
- OSV: https://osv.dev/vulnerability/CVE-2015-9238

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-9238/
Summaries are generated and may contain mistakes; the official description above is the record.
